ISPConfig 3.1 - MongoDB error, config errors, let's enrypt

Discussion in 'Developers' Forum' started by Caesar, Apr 15, 2016.

  1. Caesar

    Caesar New Member


    I've installed 3.1 yesterday, I had many problems since. At first it messed up some of the Apache vhost files, so nothing worked. I edited them or restored them from backup. Now the webs work, but I have a few other things:
    1. I get this error at least every minute (per email):
      ERROR - MongoDB is down! Rescue will not help!
      But I have not installed MongoDB, I am using MariaDB.
    2. I get this error on every ISPConfig web page configuration page:
    2016-15-04 16:04 :
    Syntax error on line 105 of /etc/apache2/sites-enabled/100-*****.**.vhost:
    RewriteCond: bad flag delimiters
    Action 'configtest' failed.
    The Apache error log may have more information.
    Websites are working, vhost files seem to be OK, the only problem is I get emailed a lot of error mails, because by every change Apache wouldn't restart properly, etc. Allthough it is working, this is rather annoying.

    3. I am generating my Let's Encrypt certs with ./letsencrypt-auto certonly, standalone server, the I symlink the certs and copy the keys to the right place in ISPConfig. I think they don't really work though, because I either get some errors, or I load a page with domain xxxx.yy, but I get shown the page aaa.yy, because that was the first one with an SSL cert on my server - completely different domain! Not for every domain though, some of them work. I have no idea why. This doesn't bother me much at the moment, because I don't really need these certs now, I have time.
    Please help me with problems 1 and 2. Also: when is the 3.1 public coming out? Is there a date yet?

    Thanks a lot for all your work, I appreciate it very much.

    Attached Files:

    • aa.jpg
      File size:
      22.9 KB
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    1) Please post it in the bugtracker.
    2) Post the exact line that is specified in the error message.
    3) ispconfig creates the certs with letsencrypt and this works fine in 3.1 as long as you hent tried to create them nauanyll in standalone mode. So do not use the standalone server mode and dont try to create any symlinks or other settings manually as this will cause your setup to fail. to install letsencrypt just do these 2 steps:

    1) Download letsencrypt.
    2) run letsenecrypt-auto --help

    Do not run any otrher commands or options from letsencrypt-auto especially do not use this command to create any certs manually outside of ispconfig.
  3. Caesar

    Caesar New Member

    Thank you, Till, I will do that. I wasn't sure how to make the certificates, so I've done it this way. Now I know I was wrong and it is much easier than I thought.

Share This Page