ISPConfig 3.1 stopped working after today's upgrade

Discussion in 'General' started by onastvar, Mar 15, 2017.

  1. onastvar

    onastvar Member

    My ISPConfig suddenly stopped working, this all happened after I ran aptitude -y upgrade

    When I run /usr/local/ispconfig/server/ I get: 14.03.2017-21:04 - WARNING - There is already an instance of server.php running with pid 20964.
    I also tried to reconfigure ISPConfig by running
    cd /tmp
    tar xfz ISPConfig-3-stable.tar.gz
    cd ispconfig3_install/install/
    php -q update.php

    but it hanged on backup step, couldn't continue.

    Also tried ISPConfig test script for common issues:
    wget -q -O htf-common-issues.php "" && php -q htf-common-issues.php

    It hangs for long time, nothing happens.

    Anyone experienced this issue on their servers,
    or know what the problem is?

    Thanks in advance?

    This is the upgrade log from today:
    tail -3 /var/log/apt/history.log
    Start-Date: 2017-03-14 16:05:41
    Upgrade: roundcube:amd64 (1.1.5+dfsg.1-1~bpo8+2, 1.1.5+dfsg.1-1~bpo8+4), roundcube-plugins:amd64 (1.1.5+dfsg.1-1~bpo8+2, 1.1.5+dfsg.1-1~bpo8+4), mariadb-client:amd64 (10.0.29-0+deb8u1, 10.0.30-0+deb8u1), roundcube-core:amd64 (1.1.5+dfsg.1-1~bpo8+2, 1.1.5+dfsg.1-1~bpo8+4), mariadb-client-core-10.0:amd64 (10.0.29-0+deb8u1, 10.0.30-0+deb8u1), mariadb-server-core-10.0:amd64 (10.0.29-0+deb8u1, 10.0.30-0+deb8u1), imagemagick-6.q16:amd64 (,, roundcube-mysql:amd64 (1.1.5+dfsg.1-1~bpo8+2, 1.1.5+dfsg.1-1~bpo8+4), imagemagick:amd64 (,, mariadb-common:amd64 (10.0.29-0+deb8u1, 10.0.30-0+deb8u1), libmagickwand-6.q16-2:amd64 (,, tzdata:amd64 (2016j-0+deb8u1, 2017a-0+deb8u1), mariadb-client-10.0:amd64 (10.0.29-0+deb8u1, 10.0.30-0+deb8u1), mariadb-server-10.0:amd64 (10.0.29-0+deb8u1, 10.0.30-0+deb8u1), imagemagick-common:amd64 (,, libmagickcore-6.q16-2-extra:amd64 (,, mariadb-server:amd64 (10.0.29-0+deb8u1, 10.0.30-0+deb8u1), libmagickcore-6.q16-2:amd64 (,
    End-Date: 2017-03-14 16:06:15
    Last edited: Mar 15, 2017
  2. onastvar

    onastvar Member

    Strange, not sure how and what exactly happened.
    After spending 3 hours, I was able to fix the issue by issuing following:

    ps -ef | grep mysqld
    mysql 2132 1890 0 Mar14 ? 00:00:05 /usr/sbin/mysqld --basedir=/usr --datadir=/var/lib/mysql --plugin-dir=/usr/lib/mysql/plugin --user=mysql --skip-log-error --pid-file=/var/run/mysqld/ --socket=/var/run/mysqld/mysqld.sock --port=3306
    root 2133 1890 0 Mar14 ? 00:00:00 logger -t mysqld -p daemon.error
    root 30990 3989 0 00:02 pts/0 00:00:00 grep mysqld
    kill -9 2132
    kill -9 2133

    service mysql start

Share This Page