ISPConfig 3.1.*: Wrong Permissions on new created Apache Access Logs

Discussion in 'Installation/Configuration' started by DennisH, Jul 20, 2017.

  1. DennisH

    DennisH New Member

    Good morning,
    we've noticed that ISPConfig creates Apache Website Access Logs with a wrong permission.
    New logs are created with Permission -rw------- (0600).
    After two days, when ISPConfig compresses the logs into a .gz, the archives are created
    with the correct file permission -rw-r--r-- (0640)

    For example:

    -rw-r--r-- 1 root root 418134 Jul 19 00:00 20170717-access.log.gz
    -rw-r--r-- 1 root root 408694 Jul 20 00:00 20170718-access.log.gz
    -rw------- 1 root root 6102137 Jul 19 23:59 20170719-access.log
    -rw------- 1 root root 1786892 Jul 20 10:45 20170720-access.log
    lrwxrwxrwx 1 root root 19 Jul 20 10:32 access.log -> 20170720-access.log

    With these wrong permissions, our customers are not able to view any of the new created log files.

    Any idea how to fix the problem?

    We have noticed this behavior only with Debian Wheezy, server with Debian Jessie/Stretch always
    create the logfiles correctly.

  2. DennisH

    DennisH New Member

    no one else is experiencing this behavior?
  3. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    I had problems with Joomla installing components with similar wrong permissions. Turns out the website no longer worked correctly with the PHP mode that been in use for ages. With Fast-CGI files had no permissions for group, just like your case. PHP-FPM and SuPHP worked OK as PHP mode.
  4. DennisH

    DennisH New Member

    Good Morning Taleman,

    today I checked if the problem still exists.
    Looks like one of the updates fixed this problem.
    I checked the changelogs but I couldn't find any hints when this problem got fixed.

    It is working now.


Share This Page