ISPConfig 3.1b1 Multi: /var/www/[site] not created on slave server...

Discussion in 'Installation/Configuration' started by jar240, May 16, 2016.

  1. jar240

    jar240 New Member

    Hi. I added a second (slave) server to my ISPConfig 3.1b1 master server (first slave, from single server setup previously). Master is 16.04, configured from "perfect server" tutorial, working with existing websites and email, etc. Slave is 15.10 configured from "perfect server" tutorial, except using the expert install and successfully connecting to master. Both running ISPConfig 3.1b1. All services are enabled on both servers.

    When I use ISPConfig on master to create a new site on the slave host, nothing is actually created in /var/www/ in the slave host. I've tried resyncing websites on the slave, resyncing all services on the slave, but still no folder.

    Does ISPConfig automatically create the "clientX" and "webX" users on slave servers? How is this supposed to work? Is there multi-server log somewhere where I might see issues?

  2. jar240

    jar240 New Member

    I bought the manual and have reviewed it. Nowhere in the manual can I find the 'next steps' for provisioning a new site on a slave web server in order for it to be served by that server (e.g. adding entry to /etc/apache/sites-available and /var/www/[site]).

    It's mentioned in the following thread that there's no rsync or any communication to the slave server other than what's in the database... how does this happen? After using ISPConfig on the master to provision a new site (for existing client) on the slave server, what are the next steps in order for the slave to actually serve the site?
  3. Jesse Norell

    Jesse Norell Well-Known Member Staff Member Howtoforge Staff

    The next step would be the slave server's ispconfig cronjob runs (once per minute), finds that it needs to create that site/user/etc. and it subsequently does so. I'm not very well versed in troubleshooting that procedure, but there is help to debug on the slave to determine why it is failing listed in the post pinned at the top of this forum, start with that, and post your results back here if that doesn't lead to the solution.
  4. jar240

    jar240 New Member

    Thanks Jesse, that definitely got me further.
    There were two problems:
    1. my hosts files were incomplete (appeared to connect after I added back the entries)
    2. I had to reset the password for the 'ispcsrv2' user in the master MySQL database. I don't know why this was the case, but I reset it to what was in the /usr/local/ispconfig/interface/lib/ file, reran "/usr/local/ispconfig/server/", and it finally connected, and did all it's business. I now see my site in /var/www/...
    This thread helped a lot:

Share This Page