ISPConfig 3 install problem - Unable to load sql-dump

Discussion in 'Installation/Configuration' started by gkovacs, Jan 5, 2009.

  1. gkovacs

    gkovacs Member

    I am trying to install ISPConfig 3 RC onto an Ubuntu system, following the install guide. After entering the MySQL credentials (our MySQL is on a different server) the following error happens:

    ERROR: Unable to load SQL-Dump into database table.
    The MySQL user does have access, as there is a successfully created database.

    What might have gone wrong, and how can I solve this problem?
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please make sure that you used the mysql root user to install ISPConfig and make sure that the database name you entered in the installer not exist already as ispconfig creates the database itself.
  3. gkovacs

    gkovacs Member

    Actually, I have tried it several times, with several users:

    1. First time, I've created a MySQL user named "ispconfig" with all root privileges. SQL dump error.

    2. Second time, I've copied the "root" user via PHPMyAdmin, with the host modified from "localhost" to the IP address of the ISPConfig host, so I have two root accounts (one is the original, new is for ISPConfig). Same error.

    None of these approaches worked beyond correctly logging in and creating the "dbispconfig" database. They all stop with the SQL dump error. I've always deleted the database and flushed privileges before trying again.

    I'm out of options. Any suggestions?
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    1 and 2 are wrong. Delete both.

    Do not create any user or database. Just start the ispconfig installer, enter the mysql root user and password and a name for the database, thats all.
  5. gkovacs

    gkovacs Member

    I HAVE TO create a user, since the current MySQL root user DOES NOT HAVE privileges from a remote host, only localhost.

    Since our ISPConfig installation is on a different physical server, I have to arrange the privileges for it's IP address.

    I DID NOT manually create any database, the installer did. However, it was unable to go any further, for a reason unknown.

    Has anyone succeeded installing ISPConfig with MySQL on a different server (not localhost)?
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    The mysql database should be located on the local server for performance reasons as postfix etc. is using it directly. ISPConfig cares itself on database replication if used on multiserver setups.

    But in general there is no problem to use a remote host as long as you enter valid database credentials for the remote server for a suer that has root priveliges. You should test the database connection from the remote host with the mysql command:

    mysql -h -u root -p

    if you are able to login then, it should work for ISPConfig as well.
  7. gkovacs

    gkovacs Member

    Turns out the problem was that I havent installed MySQL (neither server nor client) on the ISPConfig host. Installing the mysql-client package solved the issue, authentication works flawlessly.

    Thanks for your help Till.

Share This Page