ISPConfig 3 - Internal Server Error 500

Discussion in 'Installation/Configuration' started by Quatrossential, Mar 9, 2013.

  1. Quatrossential

    Quatrossential New Member

    After installing the panel ISPConfig 3, before the link http: //mywebserver:8080/, i have a problem:

    [B]Internal Server Error[/B]
    The server encountered an internal error or misconfiguration and was unable to complete your request.
    Please contact the server administrator, webmaster@localhost and inform them of the time the error occurred, and anything you might have done that may have caused the error.
    More information about this error may be available in the server error log.
    I installed it as described above THERE.

    Apache log:
    [Sat Mar 09 08:18:43 2013] [warn] [client] (104)Connection reset by peer: mod_fcgid: error reading data from FastCGI server
    [Sat Mar 09 08:18:43 2013] [error] [client] Premature end of script headers: index.php
    I have updated the panel with the command php -q update.php but it did't resolved this problem.

    Please HELP me!!!
  2. falko

    falko Super Moderator Howtoforge Staff

  3. randallrodriguezw

    randallrodriguezw New Member

    update to from didn't work too


    We had a VM with a virgin installation of Centos 6.3 and ISPConfig that was working but didn't have any domains yet.

    In our company we just are ready to start using the ISPConfig with our domains and we did what we thing is logical, to check for new versions and found the update. We updated and get the same 500 error:

    Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    We shutdown the VM, restore from a backup, updated again with the same results. Restore the VM again and updated to 3.0.5 with the same result. The machine was working and we have navigated through the options and menus and we like it very much. Also we didn't change anything never before the update. I can restore the and start to work but I found very useful the new features of the, specially the backups and security.

    any ideas? Have anyone found the same error with an update?

    Thanks in advance
  4. falko

    falko Super Moderator Howtoforge Staff

    How did you upgrade?
  5. randallrodriguezw

    randallrodriguezw New Member

    How I did it


    In the several attempts I tried at first like the software recommended with the internal script:


    With each failed attempt to start I shutdown the VM, restore it completely from the backup and tried again, then each attempt have not run over a "dirty failed scenario". I tried always with the stable version; and in different attempts I choose different between reconfigure the database (sometimes yes and sometimes no), the same with reconfigure scripts, and son on.

    After non of the attempts worked I tried downloading the tar file again, uncompressing it and running the command:

    # php -q update.php

    The same result.

    I am using Centos 6.3 and KVM.

    Thanks in advance Falko. I have been using your guidelines in Howtoforge for several different software and platforms for years.
  6. Mikeddarkman

    Mikeddarkman New Member

    I've got Error 500,too

    Hi Falko,

    after updating from to with the script, I've got a Internal 500 Server error.

    My System is Debian Squeeze on OpenVZ, setting up on your "Perfect Script". On is works fine. But what is gonig wrong now?

    [Tue Mar 19 09:58:55 2013] [warn] [client] (104)Connection reset by peer: mod_fcgid: error reading data from FastCGI server
    [Tue Mar 19 09:58:55 2013] [error] [client] Premature end of script headers: index.php
    PLS, this is urgend, of course the error is on a production system.
  7. almere

    almere Member HowtoForge Supporter

    It's possible that Zend Optimizer, EAccelerator and/or APC (if this is being used) are contributing to the issue.

    You might try disabling any or all of these by commenting them out of the global php.ini file at /usr/local/lib/php.ini and restarting Apache to see the results.
  8. randallrodriguezw

    randallrodriguezw New Member

    I will do that and...

    I am in the process of creating a new vm over kvm Fedora, and that will be with the new Centos 6.4 ISPConfig published by Falko.

    I will tell you both results in a while.

  9. randallrodriguezw

    randallrodriguezw New Member

    global php.ini


    on centos the global php.ini is at /etc/php.ini and it don't have any uncommented zend options

    Also it didn't have any eaccelerator, with or without caps neither apc too.

    Thanks almere
  10. almere

    almere Member HowtoForge Supporter

    Try to set this options to httpd.conf in <IfModule mod_fcgid.c>, so something like this:

    <IfModule mod_fcgid.c>
    FcgidIOTimeout    700
    FcgidBusyTimeout 3600
    # other stuff here

Share This Page