ISPConfig 3 not running (?)

Discussion in 'General' started by Slimat, Jul 10, 2024.

  1. Slimat

    Slimat Member

    Hi all

    I have a non-production ISPConfig installation on a virtual Ubuntu (22.04.4) server. I have been using it to develop a new Word Press site over the last several months. Stupidly I have no backup!!

    Anyway, today I powered the VM on and Ubuntu fires up OK and I have full ssh access to the ubuntu server. When I go to the IP address in a web browser I get the Apache welcome page... but when I try to go to my WordPress installation, or the ISPConfig GUI I get a "refused to connect" error in the browser.

    Unfortunately there is a lot of development which I havent backed up as it was safe (so I thought) in a shutdown VM.

    I am resigned to having lost all my work and need to start again - but I wondered whether there is a way to check if ISPConfig is the problem and whether it can be reinstalled over the top, or repaired anyway before starting again?

    Any thoughts would be gratefully received.

  2. pyte

    pyte Well-Known Member HowtoForge Supporter

    Check if the services are started and if there are any issues.
    systemctl status
    Check for running services on ports:
    ss -tunlp
    Did you change the network config of the VM and the VM now may has another IP?

    The data will not be lost just because there is an issue with the services on that machine, but you need to figure out what's not working.

    May follow and post the the output of the HTF script here.
  3. Slimat

    Slimat Member

    No, the IP address is static - I get the welcome apache web page, so know its still there. I will have a look at the link above and post the results back.
    Thanks @pyte
  4. Slimat

    Slimat Member

    OK - when I run the script, it looks like it works as there is no error - but
    cat htf_report.txt | more
    Errors with;
    cat: htf_report.txt: No such file or directory
    I am running this as root... any thoughts?
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    You said you have full access to SSH which means you still have full access to everything you developed and most likely nothing is lost.

    Regarding the thread title, there is a misunderstanding about how ISPConfig works. ISPConfig is not a service, so it can not even start. ISPConfig is basically a website, a database and a set of PHP shell scripts. So your issue is not that ISPConfig does not start, your issue is that the apache config of that system has been altered in a way that apache does not serve the ispconfig website and your wordpress site anymore.

    Regarding your issue, either you started the wrong VM, reset the VM into a stable state before installing ISPConfig, or manually altered the Apache config. But as long as you did not wipe out the hard disk, your work is not lost. You must run the test script and post the result.
  6. Slimat

    Slimat Member

    Thanks - I will keep trying then. I can confirm that its the right server as I can access my development in /var/www/clients/client1/web1/web - however as its in WordPress I need to get ISPConfig to load, so I can access the SQL Database.

    I will start looking at Apache etc to try and find the problem then. Thanks
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    Please run the test script and post the output.
  8. Slimat

    Slimat Member

    Thanks @till
    As per my previous post, when I run the script it seems to work as there is a fraction of a second delay before I get command prompt again - and there is no error.
    But, when I run;
    cat htf_report.txt | more
    I get the following error message;
    cat: htf_report.txt: No such file or directory
    So, I am unable to get the report to post.
  9. ahrasis

    ahrasis Well-Known Member HowtoForge Supporter

    SQL database? You mean mysql database right? It is easier to access database if you phpMyAdmin works but that can also be accessed from the cli (command line interface) too.

    Make sure you are root of the server, not your web site, before attempting the above advises.
  10. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Did the download work, so you got file named htf-common-issues.php ?
    How are you running the script?
    pyte likes this.

Share This Page