ISPConfig 3 Update 2/3: amavis: Can't connect to TCP port 10024

Discussion in 'Installation/Configuration' started by jnewman67, May 15, 2020.

  1. jnewman67

    jnewman67 Active Member HowtoForge Supporter

    seeing the following in my maillog after realizing mail wasn't going through:

    (!)Net::Server: 2020/05/14-21:58:04 Can't connect to TCP port 10024 on ::1 [Cannot assign requested address]\n at line 68 in file /usr/share/perl5/vendor_perl/Net/Server/Proto/
    status=deferred (connect to[]:10024: Connection refused)

    I believe this came after ISPConfig 3 update 2 was installed - this server sends minimal email (web services only)
    to resolve, I tried running the ispconfig_update to install update 3 and let it reconfigure conf files - no love
    I could see that amavisd.conf include the port assignment for 10024 and clamd was assigned to port 3310
    restarting all the mail services (postfix, amavisd, clamd courier-imap, postgrey - down in that order, up in reverse) - no love
    yum installed all found updates - no love
    tried lsof -i:10024 to find and kill dead processes - nothing to kill
    finally this post:
    • amavis: Can't connect to TCP port 10024
    • Started seeing this in the logs.. I think it was after I upgraded docker..
    • I fixed this by adding
    • $inet_socket_bind = '';
    • to the end of /etc/amavisd/amavisd.conf in the image.
    so, not sure how that line got dropped from amavisd.conf - but it wasn't there (maybe lost/not added in Update 2?)
    added that line, restarted all service as above, and it's working again!

    my server:
    "CentOS" 2.6.32-754.29.1.el6.x86_64 #1 SMP Mon Apr 27 15:30:33 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux
    hope this helps someone else looking for something that works :)
    till likes this.

Share This Page