ISPConfig 3

Discussion in 'Installation/Configuration' started by micheal-808, Oct 4, 2009.

  1. micheal-808

    micheal-808 New Member

    ISPConfig 3 Monitoring Problems

    Hello ispConfig Team, there is an error with my ispconfig 3 Installation! Monitoring was working from the beginning till today! Ive nothing changed on the Serverconfiguration. Nothing installed and nothing else is done! No Errors! But Monitoring isnt working! Serverload says 0h and 0minutes. CPU Stats arent available. HD Stats arent displayable cause it tells me there is no support also for update status. ispconfig says no supported Distribution but it was working before!

    I am using Debian 5.0.3

    It was working before. Every one Singleoption was working fine and now nothing of them works! I guess something with permissions could be the problem but i dont know where to take a look!

    Can you tell me some soulition to do a workaround?

    It weres great to become ispconfig 3 as a working panel back and thanks for supporting!

    Last edited: Oct 5, 2009
  2. damir

    damir New Member

    Do you run multiserver setup or is it single server? Do you have any errors in ispconfig.log file? Maybe you could enable debug mode so you can more easily track down the actual error.
  3. micheal-808

    micheal-808 New Member

    Thanks for your reply. It is an single Server setup!

    I'll take a look into the .log files !

    The ispconfig.log file has no entrys!

    How to start ispconfig in debug mode? There is no way to start icpconfig in debug mode or?
    Last edited: Oct 4, 2009
  4. Franz

    Franz Member


    and change line
    $conf["log_priority"] = 2; // 0 = Debug, 1 = Warning, 2 = Error
    and wait for one minute while cron execute script
  5. micheal-808

    micheal-808 New Member

    Hello, thanks for your reply.

    I did that but still no entrys in my ispconfig.log file!

    I changed the file 10 minutes ago! Unfortunately there are no entrys! Only my ispconfig_install.log file has some entrys but ispconfig.log not!

    What to do now?
  6. Franz

    Franz Member

    did you change value to 0 ?
  7. micheal-808

    micheal-808 New Member

    Yes, i changed to debugging mode!

    Thats the actual setting:

    //** Logging
    $conf["log_file"] = '/var/log/ispconfig/ispconfig.log';
    $conf["log_priority"] = 0; // 0 = Debug, 1 = Warning, 2 = Error
    Still no entry in the .log
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Then cron must be missing on your system. Please install a cron daemon.
  9. micheal-808

    micheal-808 New Member

    IMO i already have an cron daemon running!

    Thats my crontab

    MAILTO="[email protected]"
    #m      h       dom     mon     dow     user    command
    11      */6     *       *       *       ntpdate -b -s name.server.tld
    * * * * * /usr/local/ispconfig/server/ > /dev/null 2>> /var/log/ispconfig/cron.log
    30 00 * * * /usr/local/ispconfig/server/ > /dev/null 2>> /var/log/ispconfig/cron.log
    And there are the entrys from ISPConfig!

    And my ispconfig.log is still empty! What ive missed? Or do i have missunderstood you?

    edit: well, the entrys all point to cron.log file! Maybe i missed something different! But all what ive done was enough for the first days! Ive followed the guide here on! I have had no problems during the install!
    Last edited: Oct 5, 2009
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    Run this command on the shell as root user:


    do you get a entry in the ispconfig.log or the ispconfig monitor now? If yes, then you dont have cron installed. That there is a crontab does not nescessarily mean that you have cron installed.
  11. micheal-808

    micheal-808 New Member

    Thats the output:

    # /usr/local/ispconfig/server/ 
    sh: /ps: No such file or directory
    Unable to open logfile.
    And yes, sure, you are right but cronjobs are working and running! mysqldump is working day per day and also some other scripts doing his job via cron!

    ispconfig.log file has permission 644!

    And this file has
    -rwxr-x--- 1 ispconfig ispconfig 165 2009-09-30 19:55 /usr/local/ispconfig/server/
    Last edited: Oct 5, 2009
  12. till

    till Super Moderator Staff Member ISPConfig Developer

    Please make sure that you run this as root, not with any other user or sudo. The error means that your server does not has the "ps" command which is very unlikely as this is part of every linux install.

    thats OK as this job runs as root user.
  13. micheal-808

    micheal-808 New Member

    Hmmö. I run this as root! as Superuser! I changed to root with # su -

    Ive googled around and found some informations:

    The verbose output is:
    sh --verbose /usr/local/ispconfig/server/
    . /etc/profile
    # /etc/profile: system-wide .profile file for the Bourne shell (sh(1))
    # and Bourne compatible shells (bash(1), ksh(1), ash(1), ...).
    if [ "`id -u`" -eq 0 ]; then
    id -u
    if [ "$PS1" ]; then
      if [ "$BASH" ]; then
        PS1='\n \[\033[0;37m\]__________________________________________________\n \033[0;36m\][\t, \d]\[\033[0;31m\][\j]\
    [\033[0;37m\][HOSTNAME][# bashed] \n \[\033[0;37m\][\u @\[\033[0;31m\] ID]\[\033[0;37m\] \$ [\w]\n [bash] # '
        if [ "`id -u`" -eq 0 ]; then
          PS1='# '
          PS1='$ '
    export PATH
    alias ..='cd ../'
    alias ...='cd ../../'
    alias get-app='apt-get install'
    alias search-app='aptitude search'
    alias rem-app='apt-get remove'
    alias update='apt-get update'
    alias upgrade='apt-get upgrade'
    alias distupgrade='apt-get dist-upgrade'
    alias ll='ls -l'
    alias la='ls -a'
    alias las='ls -las'
    alias l='last'
    alias lb='lastb'
    alias lg='lastlog'
    umask 022
    /usr/bin/php -q /usr/local/ispconfig/server/server.php
    sh: /ps: No such file or directory
    Unable to open logfile.
    Something is wrong. Need to google around!
  14. till

    till Super Moderator Staff Member ISPConfig Developer

    Please run:

    which ps
  15. micheal-808

    micheal-808 New Member

    # which ps

  16. till

    till Super Moderator Staff Member ISPConfig Developer

    And you executed this as root user?

    Do you have selinux disabled?
  17. micheal-808

    micheal-808 New Member

    Hm, i dont know if selinux is disbabled or not!

    Ive temprarly disabled selinux:

    # echo 0 >/selinux/enforce

    and tried to run the command:

    sh: /ps: No such file or directory
    Unable to open logfile.

    Same output! And yes, i am to 100% root user !
  18. till

    till Super Moderator Staff Member ISPConfig Developer

    You have to reboot the server after you disabled selinux. Please take a look at the perfect server tutorial, it contains a chapter on how to disable selinux.
  19. micheal-808

    micheal-808 New Member

    ive disabled selinux and did a reboot, here is the output:

  20. till

    till Super Moderator Staff Member ISPConfig Developer

    Please post the output of:

    cat /usr/local/ispconfig/server/

Share This Page