ISPConfig and IPcop

Discussion in 'Installation/Configuration' started by Lozzer, May 8, 2006.

  1. Lozzer

    Lozzer New Member


    I am trying to use an ISPConfig webserver behind an IPcop firewall, on Orange.

    My problem is that they BOTH use port 81 for administration. I cannot see a way of changing the admin port on either machine, which means that I can only administer the ISPConfig webserver locally.

    Has anyone else come across this, and if so, has anyone found a way around it?

    Apologies if this is a simple question, but I am fairly new to both FC-4 and ISPConfig.


  2. MvincM

    MvincM New Member


    You must open e.g. port 82 on your firewall (open from world) then edit


    and change

    "Port 81" to "Port 82"

    and change

    "Listen 81" to "Listen 81"

    save it and restart ISPC e.g.:

    /etc/init.d/ispconfig_server restart

    Best regards,
  3. Lozzer

    Lozzer New Member

    Thanks, MvincM, I'll give it a try.

    BTW, do you have any recommendation as to which port I should use? You've suggested 82, but is this the most suitable, or does it matter?


  4. falko

    falko Super Moderator Howtoforge Staff

    As long as your ISP and/or your firewall aren't blocking any ports, it doesn't matter.
  5. Lozzer

    Lozzer New Member

    Thanks Falko, That's done the job.

    Great product, great forum. I've worked in the mainframe world for years and this is how things SHOULD work, ordinary people helping other ordinary people, with the guys who know helping where required.


  6. DVS

    DVS New Member

    Changing that port now...

    Hey guys - I have the same problem...IP Cop Vs ISPconfig
    and IP Cop is winning handsdown at the moment. (but I'm not picking sides just yet :p )

    I sucsessfully changed my port on ISP but I'm not getting the portforwarding right I'm assuming.

    I'm running the Copfilter addon - does this change my situasion from the usual default portforwarding settings and external access settings that I have to change something else with those two?

    Any ideas? :eek:

    P.S. - yes the cabel is plugged in this time...:cool:
  7. falko

    falko Super Moderator Howtoforge Staff

    Can you access ISPConfig from within your network?
  8. DVS

    DVS New Member


    Hey falko,
    I'll draw the pictur quick :)

    I have a number of static IP's...IPCop running on and ISPConfig in conjunction with "the perfect setup (Fedora 5)" running on

    My administartion pc is situated behind IPCop what I'm having trouble with is accessing ISPConf from my admin pc via IPCop.

    I can access it quite fine from "outside"...I can acces it via IPCop using Putty and winSCP. I've changed both the listening port and port nr to 96/78/777 you name it. I just cant get to it. IPCop gives me this:

    The requested URL could not be retrieved

    While trying to retrieve the URL:
    The following error was encountered:

    * Access Denied.

    Access control configuration prevents your request from being allowed at this time. Please contact your service provider if you feel this is incorrect.

    Your cache administrator is webmaster.
    Generated Wed, 24 May 2006 07:04:16 GMT by AV (squid/2.5.STABLE13)

    and thats it... Technicaly speaking this should not be difficult :confused:

    I've eaven tried listen port 81 and http port 82/../../..... but that didn't work ither :eek:

    Furthermore - I've established that it must have something to do with my "proxy-side" of IP Cop because loging into a created mail account using Firebird works just fine. As soon as I use my web browser (set to go thru my proxy server [and this brings up some other questions I have but will post somewhere else]), it konks out and give me the access problem. I'm using the advanced proxy v1.2.1 addon and there MUST be a setting that can sort this out.

    But for the moment...I'm stuck :cool:
    Last edited: May 24, 2006
  9. falko

    falko Super Moderator Howtoforge Staff

    Is ISPConfig in the green or orange network, or somewhere else?
    Did you change ISPConfig's port number?
  10. DVS

    DVS New Member

    Could it be....?

    When I set my browser settings to "automaticaly detect proxy settings", I connect to the perfect setup server with no trouble at all. As soon as I route through my Advanced IPCop proxy server I get the "control configuration prevention" problem.

    I'm wondering 1 - why can I connect to the internet even though I'm not routing thru my proxy - but my connection still runs thru my IPCop box (i would love to know how to stop this from happening actualy, i.e. forcing a connection thru the proxy server),

    and 2 - could the connection problem to my ISPConfig server be related to the fact that the domain name is not registered - thus giving IPCop Adv.Proxy reason to block the (unknown/non excistant domain name/ip address) connection?

    This is probably the wrong place to ask some of the questions - but I'm finding no other forum (in english) covering the ipcop proxy topic :confused:

    If you have an idea on the matter it would be appreciated :)

  11. DVS

    DVS New Member

    Ports etc

    Yes I tried the diffs though :-/

    I'm on the green side and ISPConfig is on red...
  12. falko

    falko Super Moderator Howtoforge Staff

    What? You're trying to connect to a domain that is not registered? This cannot work...
  13. DVS

    DVS New Member


    Yes it can...don't type in the domain - just the static IP.
    http://localhost = didn't you know? (in this case - ) works one hundred % ... thats why having a static IP is cool (and more than on even cooler). I can't register my domain before the server isn't up & running...
    Tipical my country's reasoning skills.

    It definatly has to do with the web proxy settings of IPCop though, that is certain. What exactly these settings are and how I am able to change there is a problem :-/

    And I found the awnser to my first question...hehe. I love IT. So mutch that can go wrong :p
    Last edited: May 24, 2006
  14. falko

    falko Super Moderator Howtoforge Staff

    Of course I know. But then you're trying to connect to an IP address, not a domain.
  15. taylan

    taylan New Member

    Ipcop and ispconfig email problem

    Hello Falko
    I installed ipcop and ispconfig before ipcop i could sent mail and recieve
    after ipcop i open the ports everyting works fine i can recieve emails but i cant send any email i dont know how to pointed my mail server to outside can you help me please thanks alot
  16. djtremors

    djtremors New Member


    ipcop and the orange zone is very restrictive. You need to allow all ports for it to work, this means outbound DNS and SMTP.

    my ipcop works fine at home and work and FYI there is an addon to ipcop which can change the default ports of ipcop (445,81,etc) but i haven't tested these.

    with your problem, can you make sure you your DNS is working.
    test with something like

    dig @ mx

    should get something like :

    ; <<>> DiG 9.2.3 <<>> @ mx
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 44957
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 3, AUTHORITY: 5, ADDITIONAL: 11

    ; IN MX

    ;; ANSWER SECTION: 3376 IN MX 10 3376 IN MX 10 3376 IN MX 10

    ;; AUTHORITY SECTION: 4085 IN NS 4085 IN NS 4085 IN NS 4085 IN NS 4085 IN NS
  17. freedog96150

    freedog96150 New Member

    Ipcop has a very active mailinglist. There are some forums, but nothing official. The Saving grace is that the mailling list is fully searchable. Go to and click on the support link. You will find lots of help, and they are generally very friendly.

Share This Page