ISPConfig creates a user and a database, and an FTP server, but none of these things work.

Discussion in 'Installation/Configuration' started by PeterSGT, Mar 1, 2022.

  1. PeterSGT

    PeterSGT New Member

    ISPConfig creates a user and a database, and an FTP server, but none of these things work.

    This is a fresh installation dug up from the tutorial:
    howtoforge com/ispconfig-autoinstall-debian-ubuntu/

    Because during the installation there was a problem with quotas,
    (because this installation is on a VPS server, which does not support it)
    So the installation was done from a command like this:

    wget -O - spconfig org | sh -s -- --use-ftp-ports=40110-40210 --unattended-upgrades --no-quota

    (Because this is a new account, it is not possible to add a valid link entry)

    Then during the installation another error appeared, now I do not remember what,
    but I found on the web information that should help command:

    apt-get install update-inetd

    So I restarted the server and reinstalled everything, adding the above update.

    Everything installed then without any errors, and the panel works "normally".

    I added a client, set DNS, added a site, added a database user and added a database.
    I also added an FTP account.

    Unfortunately, the FTP account doesn't work properly because filezilla connects
    to the server and stops when fillezilla try to download the directory.

    So I uploaded the WordPress files, using SSH and tried to install WordPress,
    then found that it could not connect to the database I created.

    When trying to connect to phpMyAdmin I get the message:

    mysqli_real_connect(): (HY000/1045): Access denied for user 'userWP'@'localhost' (using password: YES)

    Then from phpMyAdmin I logged into the database as root,
    and I also did a test as pma and it is possible to log in.

    Logging in as root I can see the database created (for Wordpress)
    and the user from phpMyAdmin level.

    When I added another user to the database for WordPres from phpMyAdmin,
    then logging in from phpMyAdmin also works.

    Theoretically I am now able to install WordPress,
    but it still does not work with ISPConfig, also the FTP does not work.

    I have also checked root and pma in the configuration files (passwords), and they are correct,
    moreover it is possible to log in using root and pma and in the databases operated by them
    I can also see the changes made with the help of the ISPConfig panel.

    Does anyone have any idea what else to check?

    I am not a server specialist, I am just learning this, so please forgive me if I have described something wrong - Best Regards
  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    ahrasis likes this.
  3. nhybgtvfr

    nhybgtvfr Well-Known Member HowtoForge Supporter

    for the wordpress database user login, maybe you have php-fpm chrooted by default? so it may not be able to connect to the mysql
    socket. try setting the db host in wp-config.php to

    for ftp, it sounds like you either haven't configured a masquerade address, or you haven't opened the required ports for passive ftp, either in the ispconfig (ufw) firewall, on in any other firewall that might exist in front of your server.

    you don't say where your vps is hosted. i've posted instructions on here previously for adding quota support for ubuntu instances on amazon AWS. search for terms like 'ec2' 'quota' should find them. also search google for ubuntu, quotas and digitalocean should return results showing how to add quota support into a digital ocean droplet.
    ahrasis likes this.
  4. PeterSGT

    PeterSGT New Member

    Thanks for the reply...
    Everything is ok now.
    For the database, I didn't notice that ISPConfig adds the client name to the database name and the user name, and I was copying that data mindlessly from notepad ;-) so it's my fault.

    And in the case of FTP, even though I added a port to the firewall, FTP was still blocked because the server on which I installed it also had its own firewall which I didn't know about, so when I turned it off FTP started working.
    Thank you for your help !

    I'm just getting to know VPS and ISPConfig and I'm starting to like it ;-)
    But before I installed ISPConfig properly I didn't sleep for 3 days ... and finally I did it... (the beginning is hard)
    Regards !
    Th0m likes this.

Share This Page