ISPConfig damaged my /etc/group ! :-/

Discussion in 'General' started by NIXin, Apr 21, 2008.

  1. NIXin

    NIXin New Member

    Hi all,
    I just logged in to my box via SSH and saw a message:
    id: cannot find name for group ID 0
    I started investigating, before I could do anything at all, I noticed that apache is dead.

    I've tried the following:
    [email protected]:~# /etc/init.d/apache2 force-reload
    apache2: bad group name www-data!
    [email protected]:~# /etc/init.d/apache2 restart
     * Restarting web server apache2
    * We failed to correctly shutdown apache, so we're now killing all running apache processes. This is almost certainly suboptimal, so please make sure your system is working as you'd expect now!
    apache2: bad group name www-data
    It didn't start. Bad group name? What's going on? So I immediately took a look at /etc/group. Before I have even pressed the F3 key which is View in Midnight Commander I noticed that the file is WAY to small (39 bytes). It had only one user inside. This wasn't cause of hacking or anything, I know the cause (ISPConfig). How do I know that? Because I was just editing the user that was lest in the truncated /etc/group. The whole file was this:
    Anyway... I just found out that I don't have a recent backup of /etc/group file. I'm using suPHP, so it's a must for me (error 500 otherwise). I recovered a group file from October 2007, but many newer sites I have created don't work. Not to mention some other broken stuff (didn't test ftp yet).
    So... is there a way to recreate the /etc/group file, or at least to fetch the user list to recreate it manually?

    Have a nice day. Thanks in advance!
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    ISPConfig does not damagae group file which has the correct format. The group file must have been corrupted before you edited this user or another application was editing the group file at the same time. Do you run webmin on the server too?

    To let ISPConfig recreate the groups, execute the following SQL staement in the ISPConfig database:

    update isp_isp_user SET status = 'u' where status = '';

    Then edit a user in the interface, change something and click on save.
  3. NIXin

    NIXin New Member

    Thanks, I'll try it in a second. But, I don't have webmin, and nothing else was accessing the group file. It's like it vanished when ISPConfig was editing it.
    One other thing started happening after this - the /etc/apache2/vhosts/Vhosts_ispconfig.conf doesn't get updated automatically. A file is created like this: Vhosts_ispconfig.conf_21-04-08_22-56-09, and it has current data inside, but the "Vhosts_ispconfig.conf" doesn't get replaced. What's the problem?
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    If you fix the gruop file probelm, this problem will be solved too.
  5. NIXin

    NIXin New Member

    You are correct, it worked! Many thanks.
    But I still don't know how did it come to this. :/

    Have a nice day.

Share This Page