ISPConfig Dovecot Postfix Mail issue

Discussion in 'Installation/Configuration' started by Monotoba, Aug 15, 2019.

  1. Monotoba

    Monotoba Member

    Hi All,

    I am moving an existing ISPConfig 3 server to a new VPS. On all my previous servers I have installed everything myself. This service offered to install ISPConfig 3.1 for me and so I opted in. However, when I logged in I found the domain name was incorrect, the host name was an internal machine name, and no mail server was installed. The version of ISPConfig installed has long ago been updated to newer versions some with security fixes. So I removed ISPConfig and started over. Most of the packages were already installed. But I executed every command in the Ubuntu 18.04 Perfect Server setup except for quotas (already existed). I also did not install chat, or dns.

    After that I got everything up but mail. Postfix was starting and exiting immediately. However, I didn't see a postfix error in the logs. I did find however that Dovecot is exiting with error code 89. Roundcude gives "cannot connect to storage" on attempted logins. Mail does not show up in the Show Services list. Yet, the summary says everything is ok and all needed services are up. I've looked through config files but don't really know what I am looking for when it comes to mail servers. Here is some helpful info from the system:

    OS: Ubuntu 18.04
    ISOConfig 3.14p2

    I do get this error:
    $> ls -l /var/spool/postfix/private/auth
    ls: cannot access '/var/spool/postfix/private/auth': No such file or directory

    I have also attached the Postfix and Dovecot configurations for additional info.

    Any help or info on how to proceed would be greatly appreciated!

    Attached Files:

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Try to run an ispconfig update with reconfigure services = yes to see if the updater is able to fix your config.
  3. Monotoba

    Monotoba Member

    I tried that. Did not work. First update attempt with ispconfig_update.php responded with no updates available. So I downloaded ispconfig again into /tmp, extracted it and ran php -q update.php. I chose to reconfigure and tried once without redoing the certs and then again with recreating the certs. Same results. Roundcube response with "cannot connect to storage" and netstat reports (see attachment). Rebooting or manually restarting the mail services does not work either. However, now in mail.err I see this:
    (Since I ran update and reconfigured service I am including the latest version of the configs and some relevant commands in the attachment.)
    tail mail.err

    Aug 16 01:20:38 www postfix/smtpd[52277]: fatal: no SASL authentication mechanisms
    Aug 16 02:05:38 www postfix/smtpd[54502]: fatal: no SASL authentication mechanisms
    Aug 16 02:05:39 www postfix/smtpd[54504]: fatal: no SASL authentication mechanisms
    Aug 16 02:31:08 sensornet postfix/smtpd[3843]: fatal: no SASL authentication mechanisms

    Attached Files:

    Last edited: Aug 16, 2019
  4. Monotoba

    Monotoba Member

    Would it be feasible to apt purge postfix and dovecot and then just go through that portion of the perfect server setup again, then re-run update.php?
  5. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    You wrote about the preinstalled ISPConfig:
    Maybe the provider does not install postfix because the host does not have port 25 open? So it could not be used as mail server anyway.
  6. Monotoba

    Monotoba Member

    I will check with them. If so, I'll need a refund! Their material said nothing about not hosting mail servers only that you could not run an open mail relay. However, that still wouldn't cause the issues I'm having. Even if the mail server wasn't accessible from out side it should still start and be accessible on local host.
    Also, I don't think that would cause the error messages I am getting in the logs.
    Last edited: Aug 16, 2019
  7. Monotoba

    Monotoba Member

    Ok, they do not block email ports and they do allow email servers. They just wont, help you if your ip gets blocked do to spam emails.
  8. Monotoba

    Monotoba Member

    Ok, I apt remove --purge postfix dovecot and then reinstalled these packages and edited config files as per the perfect server setup and I now have a working email service. SMT and POP service are now listed in show services. So I hope I've solved this issue.
    till likes this.

Share This Page