ISPConfig http error 500

Discussion in 'Installation/Configuration' started by Fire Fox, Feb 19, 2021.

  1. Fire Fox

    Fire Fox Member

    It's been three ours I tried to solve this problem but to no avail. The problem is I cannot access my ISPConfig 3.2.2 at https://sub.domain.tld:8080. The message on the browser:

    This page isn't working
    sub.domain.tld is currently unable to handle this request
    Http error 500

    I never encounter any problem with ISPConfig since I installed it. Not a problem since upgrading from ISPConfig 3.2

    Apparently the problem start when I tried to redirect domain1.tlda to domain2.tldb. I did this in website > domain1.tlda > redirect.

    I do this several times and no problem. But today I did it wrong. I suppose to redirect:
    - domain1.tlda to domain2.tldb
    but this is what I did (the from and to are of the same FQDN):
    - domain1.tlda to domain1.tlda
    since then accessing ISPConfig return http error 500.

    I've tried to force update ISPConfig but it didn't work:
    Code: --force
    Here some of the error:
    cat /var/log/apache2/error.log

    [Fri Feb 19 18:00:19.719718 2021] [core:warn] [pid 4763:tid 139721174248512AH00045child process 4766 still did not exit, sending a SIGTERM
    [Fri Feb 19 18:00:19.719892 2021] [core:warn] [pid 4763:tid 139721174248512AH00045child process 4767 still did not exit, sending a SIGTERM
    [Fri Feb 19 18:00:21.722131 2021] [core:warn] [pid 4763:tid 139721174248512AH00045child process 4766 still did not exit, sending a SIGTERM
    [Fri Feb 19 18:00:21.722238 2021] [core:warn] [pid 4763:tid 139721174248512AH00045child process 4767 still did not exit, sending a SIGTERM
    [Fri Feb 19 18:00:23.724506 2021] [core:warn] [pid 4763:tid 139721174248512AH00045child process 4766 still did not exit, sending a SIGTERM
    [Fri Feb 19 18:00:23.724632 2021] [core:warn] [pid 4763:tid 139721174248512AH00045child process 4767 still did not exit, sending a SIGTERM
    [Fri Feb 19 18:00:25.726864 2021] [core:error] [pid 4763:tid 139721174248512AH00046child process 4766 still did not exit, sending a SIGKILL
    [Fri Feb 19 18:00:25.727450 2021] [core:error] [pid 4763:tid 139721174248512AH00046child process 4767 still did not exit, sending a SIGKILL
    [Fri Feb 19 18:00:26.729390 2021] [mpm_event:notice] [pid 4763:tid 139721174248512AH00491caught SIGTERMshutting down
    [Fri Feb 19 18:00:26.849550 2021] [suexec:notice] [pid 8767:tid 139758645443648AH01232suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)
    Fri Feb 19 18:00:26.912426 2021] [mpm_event:notice] [pid 8778:tid 139758645443648AH00489Apache/2.4.46 (Ubuntumod_fcgid/2.3.9 OpenSSL/1.1.1j mod_wsgi/4.6.8 Python/2.7 configured -- resuming normal operations
    [Fri Feb 19 18:00:26.912477 2021] [core:notice] [pid 8778:tid 139758645443648AH00094Command line'/usr/sbin/apache2'

    [Fri Feb 19 20:26:02.640070 2021] [proxy_fcgi:error] [pid 3593:tid 140717517903616] [client 182.1.xx.xx:56726AH01071Got error 'PHP message: PHP Warning:  require_once(/usr/local/ispconfig/interface/lib/ failed to open stream: Permission denied in /usr/local/ispconfig/interface/web/login/index.php on line 31PHP message: PHP Fatal error:  require_once(): Failed opening required '../../lib/' (include_path='.:/usr/share/php') in /usr/local/ispconfig/interface/web/login/index.php on line 31'
    [Fri Feb 19 20:45:59.600201 2021] [proxy_fcgi:error] [pid 3593:tid 140717517903616] [client 182.1.xx.xx:58570AH01071Got error 'PHP message: PHP Warning:  require_once(/usr/local/ispconfig/interface/lib/ failed to open stream: Permission denied in /usr/local/ispconfig/interface/web/login/index.php on line 31PHP message: PHP Fatal error:  require_once(): Failed opening required '../../lib/' (include_path='.:/usr/share/php') in /usr/local/ispconfig/interface/web/login/index.php on line 31'
    OS :  Ubuntu 20.04
    webserver :  Apache 2.4.46 Ondrej dist.
    php :  7.4.15 Ondrej dist.
    Server version: Apache/2.4.46 (Ubuntu)
    Server built:   2020-08-10T12:32:13
    PHP 7.4.15 (cli) (built: Feb 14 2021 14:20:08) ( NTS )
    Copyright (c) The PHP Group
    Zend Engine v3.4.0, Copyright (c) Zend Technologies
       with Zend OPcache v7.4.15, Copyright (c), by Zend Technologies
    cat /var/log/apache2/suexec.log
    [2021-02-19 16:04:49]: uid: (1003/ispconfig) gid: (1004/ispconfig) cmd: .php-fcgi-starter
    [2021-02-19 16:04:49]: uid: (1003/ispconfig) gid: (1004/ispconfig) cmd: .php-fcgi-starter
    [2021-02-19 16:04:49]: uid: (1003/ispconfig) gid: (1004/ispconfig) cmd: .php-fcgi-starter
    The other domains seems not affected. they can be accessed as usual

    I tried to access ISPConfig using IP and using other domains https://domains.tld:8080 but the browser keep returning http error 500

    Thank you for sharing
  2. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

  3. Fire Fox

    Fire Fox Member

    Thanks a lot Th0m, it works for me
    at the moment the repo has been rectify by Sury and following your suggestion i just update and upgrade my ubuntu 20.04 to fix http error 500
    Gwyneth Llewelyn and Th0m like this.

Share This Page