ispconfig inside a xen vm?

Discussion in 'Installation/Configuration' started by aqua, May 11, 2006.

  1. aqua

    aqua New Member


    I am trying to install the ispconfig system inside a xen vm.

    Once i get to this line:

    mysqladmin -h -u root password *******

    I got this:

    mysqladmin: connect to server at '' failed
    error: 'Lost connection to MySQL server during query'

    So i commented out the bind-address and I tried to command again, and I got this:

    mysqladmin: connect to server at '' failed
    error: 'Host '' is not allowed to connect to this MySQL server'

    I even tried defining the the vm01 hostname in /etc/hosts and it didn't work.

    Output of netstat:

    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 *:mysql *:* LISTEN 922/mysqld
    tcp 0 0 vm01.coronohosti:domain *:* LISTEN 825/named
    tcp 0 0 localhost.locald:domain *:* LISTEN 825/named
    tcp 0 0 *:ssh *:* LISTEN 970/sshd
    tcp 0 0 localhost.localdom:smtp *:* LISTEN 863/exim4
    tcp 0 0 localhost.localdoma:953 *:* LISTEN 825/named
    tcp 0 0 vm01.coronohosting.:ssh ESTABLISHED995/sshd: admin [pr

    Any suggestions?
    Thank you

    Any suggestions?
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    I guess your problem is not related to ISPConfig or xen, maybe there is no permission record for in your mysql users database table that you can change.

    You can skip this step and check later with e.g. phpmyadmin if there is another permission record where the password must be set.
  3. falko

    falko Super Moderator ISPConfig Developer

Share This Page