ISPconfig install not creating ispconfig vhost

Discussion in 'Installation/Configuration' started by [email protected], Feb 11, 2020.

  1. Hi all
    I have have reinstalled several times now ISPconfig on Debian 10 with different methods, By the perfect server direction, an two different auto install scripts. always with same result, that there is no ispconfig vitual host created.
    root@myhost:~# netstat -peal |grep apache
    tcp6 0 0 [::]:http [::]:* LISTEN root 79756 3678/apache2
    root@myhost:~# ls /etc/apache2/sites-available/
    000-default.conf default-ssl.conf
    default test web comes up. I have few other ISPconfig servers that have in an ispconfig.vhot and ispconfig.conf in the sites-available dir.
    Is it safe to copy those between servers or do they need to be generated by install, I have had bad luck with this renewal of my installations sine even Mariadb did only listen on ipv6 on default setup, and it took little time to figure out that there is missing sudo in frpnt of the a2??? commands in de perfect server directions, just wanted to point that out.
    However this is the first time in years that ISPconfig has been failing in install.
    Regards Stefan
  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    What page is that?
    I quess it would be safe, but I suspect there is something seriously wrong with ISPConfig installation so just copying that file is not enough of a fix.
    Debian 10 installation of ISPConfig does not use sudo.
    On what kind of host are you installing? Some virtual hosts have been problematic according to previous posts on these forums. Pay attention to the starting conditions for ISPConfig install, the host OS must also be installed following the instructions.
    If you have problems, forget the auto install scripts. They are more fragile compared to doing the installation following the Perfect Server Guide.
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    That's quite strange, please post the complete install output of the ispconfig install.php script that you got during installation including the input that you entered for the various questions (except passwords of course).

    Thats probably possible but your system would fail on next update. You have to find out what the reason is to get a stable system.

    You did follow the perfect server Debian 10 to the letter and did not use any packages from other sources?
  4. Hi
    Yes I followed the Debian 10 perfect server to the letter from OS and on as root on the host, I skipped Mailman since it will not be used at all. The setup ran normal with out any errors except for Defaut shell where dash is unknown (I assumed I was using bash since dash is unknown) and the missing sudo in apace commands that do not run as root, even ispconfig install.php ran normally and completed.
    I have been setting those servers up on HyperV (2016) and Vsphere (6.7) virtual machines. I finally got two up after day or so of fixing ipv6 only (on web server and MariaDB) and db permissions and lots of troubleshooting.
    I also used the auto script in and answered all questions as asked and that did not result in another outcome.
    My theory is that some thing has changed in the Debian 10 distro as I said one that I installed in December came up with relatively easily (MariaDB stuck on ipv6 only) but once I started late February to keep on setting more up nothing worked.
    Regards Stefan
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    There is no sudo missing in any command of the guide, you MUST be logged in as root user for all commands in the setup. see the text at the beginning of the guide. If you are not logged in as root, then the setup must fail. Using sudo is not an alternative, so if you used sudo anywhere in the guide instead of being logged in as root user or using 'su -' at the beginning, then it's to be expected that parts of the system will not work.
    Last edited: Feb 12, 2020
  6. Setup is done as root using su otherwise it would not work.
    The following commands do not run with our presiding sudo
    In Apache setup:
    a2enmod suexec rewrite ssl actions include dav_fs dav auth_digest cgi headers actions proxy_fcgi alias
    a2enconf httpoxy
    In PHPMyAdmin setup
    a2enconf phpmyadmin
    They error without the sudo and do not enable modules or configs, but run with it and do enable all appropriate stuff.
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    As mentioned before, not a single sudo command is missing.

    You probably used 'su' and not 'su -' as you were told in the guide. There is a huge difference between the two commands as you can't use many base commands from 'su' while they work from 'su -' because 'su -' sets a different PATH variable. In Debian 9, there was no difference, but in Debian 10, they behave completely different. Using just su results in the same failures than using sudo and it also explains why the a2enconf and a2enmod commands failed and why the ispconfig vhost is missing. Please follow the guide to the letter. The tutorial contains at the beginning:

    when I add such a sentence then you can believe me that there is a good reason for it. Same for the auto installers of course, running them as su instead of su - or a direct login as root must cause a failure.
  8. That can be an explanation this hyphen got caught in my dyslexia :)
    I will try again with the hyphen
    Thank you.
  9. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    I think you should use
    su -
    sudo -i
    instead of su when starting root session. Then a2enconf would be in path and work.
  10. Hi
    I'm sorry for late reply's, I have already tried using su - and the above mentioned install script that failed totally and did not even install PHP.
    Then I started over and finished Debian 10 Perfect Server using su - which worked fine I got now functional Debian10 ISPConfig sever.
    Even though I've been using and administering Linux since the beginning of century I really had never come across this, an find it useful info for the forum to admit that.
    Thank you for the help
    Regards Stefan
    till likes this.

Share This Page