ispconfig installation error on ubuntu 22.04

Discussion in 'Installation/Configuration' started by Loucmane KONATE, Aug 17, 2023.

  1. pyte

    pyte Well-Known Member HowtoForge Supporter

    "Intel" is a processor manufacturer not an architecture. X86, X86_64, ARM, ARM64 are architectures. To check which architecture the systeme has you can run "uname -a" the end of the command will state something like this "X86_64 GNU/Linux"
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    And if you have this issue on an Intel or AMD X86_64 architecture, then your system is not clean or contains other repositories as the auto installer works fine on Ubuntu 22.04 as you can see in post #12. So the issue is in your system base image and not in the auto-installer.
    ahrasis likes this.
  3. Loucmane KONATE

    Loucmane KONATE New Member

    here is the result

    oucmane@ispconfig:~$ uname -a
    Linux ispconfig 6.2.0-26-generic #26~22.04.1-Ubuntu SMP PREEMPT_DYNAMIC Thu Jul 13 16:27:29 UTC 2 x86_64 x86_64 x86_64 GNU/Linux
  4. pyte

    pyte Well-Known Member HowtoForge Supporter

    So your architecture is "x86_64" indeed. Read what till already said:

    ahrasis likes this.
  5. ustoopia

    ustoopia Member

    Today I ran into the same issue. And I should mention first that my server was not totally clean fresh install, since I used the built-in tool to install several apps before I ran the ISPConfig installer. And that is exactly what was causing the issue. So I learned a valuable lesson that a clean server is a requirement for good reasons.
    When I ran into this issue I manually tried to install all the PHP packages as Till mentioned earlier on this page, and this gave the following error:

    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:
    The following packages have unmet dependencies:
     php8.1-gd : Depends: libgd3 (>= 2.3.3) but 2.3.0-2ubuntu2 is to be installed
     php8.2-gd : Depends: libgd3 (>= 2.3.3) but 2.3.0-2ubuntu2 is to be installed
    E: Unable to correct problems, you have held broken packages.
    So I entered: apt install libgd3, and this showed me the following:
    The following packages will be REMOVED:
      libgd3:i386 libgphoto2-6:i386 libwine:i386 wine32:i386
    The following packages will be upgraded:
    1 upgraded, 0 newly installed, 4 to remove and 1 not upgraded.
    Afterwards I was able to install all the PHP packages fine, and this resolved the issue for me, and I was able to install ISPconfig fine afterwards. Looking at the lines above I concluded that Wine was somehow involved in causing this issue.
    I know that ISPconfig should only be installed on a clean install of the server, and for that reason I didn't ask for any help here since I was not following this requirement. But I decided to post my findings here anyways, since it may help out other people who also ignored the requirements of a clean server install.
    till likes this.
  6. BrettP-

    BrettP- New Member

    --This worked for me.
    sudo -s

Share This Page