ISPConfig installation problem. Cannot make OpenSSL

Discussion in 'Installation/Configuration' started by BlueStream, Oct 15, 2005.

  1. BlueStream

    BlueStream New Member

    Hey there..

    I have a problem. To put it simply, the setup exits with the error, "Could not make OpenSSL"

    At first i thought that maybe i had forgotten to install openssl earlier, (according to the "Perfect Fedora Core 4 Setup").

    So i did a "yum install openssl" which worked fine.

    After deleting the folder that i had extracted from the tarred installation file, i untarred it again, and ran "setup" again.

    It exitted with the same error.


  2. till

    till Super Moderator Staff Member ISPConfig Developer

    There must be some errors in the output before the line "Could not make OpenSSL". Please post them here.
  3. BlueStream

    BlueStream New Member

    Thanx mate...

    It turns out i didn't have GCC installed! DOH!!! of all the things to forget...

    Just did a fresh reinstall u see.. and my GUI installer's got some probs :p

    Anywayz.. i'm just wondering if the absence of GCC also led to another problem earlier..

    With the perl console, i couldn't "install DB_File"

    prolly gonna try that later..

    Cheers... Will update yer... :D
  4. themachine

    themachine New Member HowtoForge Supporter


    I would say you are correct with that assumption... GCC would be required to 'make'/compile the perl module.

    And no worries my friend, I forgot GCC the first time and failed at OpenSSL as well. ;0
  5. BlueStream

    BlueStream New Member


    it shouldn't be a problem if i install the perl module after i finish installing ISPConfig rite?

    Cuz its taking pretty long to setup and if it stops halfway now, i'd die! lol...
  6. falko

    falko Super Moderator Howtoforge Staff

    No, no problem at all! :)
  7. BlueStream

    BlueStream New Member

    ARRGGHH!!!! lol

    The install failed halfway last nite because of some missing dependancy called Bison... Darn it...

    So i did a Yum Install of Bison... Bison installed OK

    And i tried to do my Perl->install DB_File which still failed...

    So i tot, what the heck, i might as well forget about that altogether.

    So i deleted the isntall_ispconfig folder, reextracted it.. again... and ran SETUP.

    ARggh!!! It failed at installing PHP.

    Something about a lex command...

    So i did yum install lex

    apparently, there was no such program.

    so i tried yum install flex...
    and reran setup... i got up right till the mySQL part.... where i entered the wrong info!! DOH!!!!!!

    The installation then stopped..

    Anyway i can edit the info i inputted after the fact?
  8. falko

    falko Super Moderator Howtoforge Staff

    No, you have to delete the install_ispconfig folder, extract it again and run the setup again.

    Hm, I guess you didn't follow the "Perfect Setup" for Fedora exactly, because I've never had such problems... :D
  9. BlueStream

    BlueStream New Member

    aw man..

    haha.. maybe not "exactly" :p
    I sorta followed the guide after i found it, which was after i installed Fedora with almost similar settings... heehee....

    Will do a reinstall then.. there goes another 3 hours!! DOh!!! :p

    I'll make sure i press everything nice and slow this time.. heehee

    Thanks guys.. :D Been a great help!!! :D
  10. BlueStream

    BlueStream New Member

    Hey bros...

    Reinstalling simply by deleting the ispconfig folder and untarring it again doesn't work.. presumably because my installation(earlier one) stopped too late in the installation... pardon the redundancy... :p

    Is there anyway i can actually start from scratch?

    The error I get is:

    All prerequisites are fulfilled.
    Here we go....

    Warning: main( failed to open stream........
    I assume u know the rest... :p

    At the end of it all it says, Congratulations, Your ISPConfig system is now installed... etc....

    Heehee... Or shld i just save us all the trouble and just do a reinstall of the entire system and use my newfound knowledge and experience to prevent me from making anymore mistakes.. wahaha.... :p

    Cheers guys. and thanx again... :D
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    To run a clean install of ISPConfig after some previous installations fail, do the following steps:

    1) Delete the install_ispconfig folder.
    2) Delete the directories /root/ispconfig and /home/admispconfig
    3) Delete the mysql database, if it was created or chose for the new installation attempt another database name. It is nescessary for the installer that no database with the name you chose exists.
    4) After the installation, check your httpd.conf if there is a duplicated section at the end of the file. If so, delete the duplicate section so that the vhost configuration file is included only once.
  12. BlueStream

    BlueStream New Member

    Thanks Till... tried it but it failed at the part where i had to input my mySQL password.

    I just did a by-the-letter reinstallation of the perfect Fedora Core 4 Setup on another computer and it worked beautifully. So I'm prolly gonna do that with the computer that i've been having so many problems with. The only problem i faced with this new installation on this new computer was that i accidentally input, right at the end, the hostname as instead of just "www".

    heehee.. got a little to confident at the end and put the guide away... :p

    So all the links that were in the adminPage pointed to the wrong URL.. the FQDN ended up pointing to I managed to change some data in my hosts file to temporarily point the links in the right direction.
    I then managed to access the ISPConfig admin page and change the value in for hostname so that it becane "www" while the domain remained so that the FQDN became and then i "reset" my hosts file. I also changed the NS1 and NS2 from to (Ignore this if you want. Gonna make a new NS later). But the following links still point to the old and wrong entry->

    Under the Management "tab"....
    Everything in the System Config Folder, the Form Designer Folder and the Server Folder and the link for the Recycle Bin. They all point to the old and wrong URL whereas all the other links point to the new and updated one...

  13. falko

    falko Super Moderator Howtoforge Staff

    You can change the URL in /home/admispconfig/ispconfig/lib/
  14. BlueStream

    BlueStream New Member

    YES!!! WOOHOO!!! IT WORKED!!!!!
    Thanx mate!!!!!

    I'm home free.....
    Now just gotta do a reinstall on the other com!!! woohoo!!! :D:D

    You guys rock!!!! :D

    Thanx again everybody!!! :D

Share This Page