ispconfig login problem

Discussion in 'Installation/Configuration' started by diehard67, Sep 18, 2006.

  1. diehard67

    diehard67 New Member

    ok I just setup ispconfig, it said username and password were admin, I tried that and it told me I can't login error 101, how can I manuley change the username and password for isp config:confused:
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Have you created the mysql database manually before you installed ISPConfig?
  3. diehard67

    diehard67 New Member

    login problem ispconfig

    yes I did, it's empty
  4. wiremeister

    wiremeister New Member

    Same problem here

    I'm experiencing the same problem. Setup will locate MySQL, but does not populate the database. I'm noticing a couple of errors at the end of the setup routine:

    Connected successfully to MySQL server
    Es ist schon eine Datenbank mit dem Namen isp vorhanden!
    ls: /etc/httpd/conf.d/*.conf: No such file or directory
    ls: /etc/httpd/conf.d/*.conf: No such file or directory
    ls: /etc/httpd/conf/vhosts.d/*.conf: No such file or directory
    ls: /etc/httpd/conf/vhosts.d/*.conf: No such file or directory
    Restarting some services...
    Shutting down postfix: [ OK ]
    Starting postfix: [ OK ]
    Shutting down proftpd: [FAILED]
    Starting proftpd: [ OK ]
    Starting ISPConfig system...
    /root/ispconfig/httpd/bin/apachectl startssl: httpd started

    Warning: mysql_fetch_array(): supplied argument is not a valid MySQL result resource in /root/ispconfig/scripts/lib/ on line 47
    No results found!ISPConfig system is now up and running!
    Congratulations! Your ISPConfig system is now installed. If you had to install quota, please take the steps described in the installation manual. Otherwise your system is now available without reboot.
    Please direct your browser to

    and log in:
    Username: admin
    Password: admin

    Till, could use your help with a translation of the German!

    Here is also the syntax of /root/ispconfig/scripts/lib/ in and around line 47:

    * Server Einstellungen
    * V1.0 ISPConfig SERVER Modules
    $link = @mysql_connect($go_info["server"]["db_host"], $go_info["server"]["db_user"], $go_info["server"]["db_password"])
    or die("Could not connect to MySQL server!");
    $server_params = mysql_query("SELECT * FROM isp_server WHERE doc_id = '".$go_info["isp"]["server_id"]."'");
    if(!$go_info["isp"]["server_conf"] = mysql_fetch_array($server_params)){
    die("No results found!");
    } else {
    foreach($go_info["isp"]["server_conf"] as $key => $value) {
    $value = trim($value);
    while(strlen($value) > 1 && substr($value,-1) == "/") $value = substr($value,0,strlen($value)-1);
    $go_info["isp"]["server_conf"][$key] = $value;
    $key = NULL;
    $value = NULL;
    $server_params = mysql_query("SELECT server_ip FROM isp_server_ip WHERE server_id = '".$go_info["isp"]["server_id"]."'");
    while ($row = mysql_fetch_array($server_params)) {
    $ips[] = $row['server_ip'];
    $go_info["isp"]["server_conf"]["ips"] = $ips;

    $go_info["modules"]["string"] = "string";
    $go_info["modules"]["file"] = "file";
    $go_info["modules"]["system"] = "system";
    $go_info["modules"]["mail"] = $go_info["isp"]["server_conf"]["server_mta"];
    $go_info["modules"]["procmail"] = "procmail";
    $go_info["modules"]["dns"] = "bind";

    Have tried recompiling severl times. Same result! Help!:eek: Had this up and running one time, but server crashed and can't seem to reload. MySQL is set up, with permissions, passwords, etc..
    Last edited: Sep 19, 2006
  5. diehard67

    diehard67 New Member

    ok I got it to work but it is fun

    make a backup copy of the ispconfig dir in the root's home dir, install isp config agane, this puts data in the database but brakes the install, that is wyhy u have to backup first, restore your backup and it should work 4 u
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    The ISPConfig installer creates a database during the installation itself, if you create the databse manually, the installation will fail!



    Delete the database that you created manually and then run the ISPConfig installer again without creating any databases manually!
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    For the correct installation, please see my post above.
  8. wiremeister

    wiremeister New Member

    That did it

    Thanks Till!

    Deleted the database, and all went fine. Up and running again. Thanks for all your good work!

Share This Page