ISPConfig on Fedora Core 5 32bit system

Discussion in 'Installation/Configuration' started by StoddardIV, Jul 8, 2006.

  1. StoddardIV

    StoddardIV ISPConfig Developer ISPConfig Developer

    Hey, I'm new here, and have only been using linux for a little while, and still consider myself inexperienced. I followed the How-To 'Perfect Setup: Fedora Core 5' exactly (except I changed it to work on the 32bit), and this is my issue:

    I have installed ISPConfig. It was going smoothly up until it asked for the hostname and domain. I have a website, and I kept putting 'www' into hostname and the domain name, but it could never reach that URL. So I left 'hostname' blank and just typed in the network IP address for the domain. That satisfied it. Now here's the problem.

    I'm trying to move my existing website onto my own server. The server is on a high-speed network in my office (I operate a small business). I have a Linksys Router, and that's how the server connects to the internet. I'd like to know what I have to do so that I can get the server to start hosting websites that are accessible to everyone. In the office, I type it's (it's static IP address) with the https at the front and 81 at the back, and get the ISP config. But when I try to type in the public internet IP address, it just doesn't ever load - it times out eventually. Any help would be greatly appreciated.
  2. freedog96150

    freedog96150 New Member

    When asked for a host name what is intended is the name of the server. So for instance, if you wanted then you would enter as the hostname. Since you left it blank, there is no name for the server (except localhost), so the only way to access it is via the IP. Thankfully this is an easy fix.

    Make sure that you have configured your Linksys to forward Port 80 to the internal IP of your server. Most likely, the port is still closed and that is why you are getting the timeouts. On Linksys, the port forwarding functions are most likely on the tab that reads "Applications & Gaming", but that will depend on the exact Linksys model that you have in your office.

    caveat! Once you open your network like this, you invite all kinds of problems into your life. Please, please, please read the forums, and in particular, read threads that have to do with securing your server.

    Start there and let us know if that helped with outside access to your web server. Post here either way so that we know.
  3. StoddardIV

    StoddardIV ISPConfig Developer ISPConfig Developer

    I forwarded all ports (1-255) to the server. I can get the ISPConfig screen from outside the network now, but I just have more questions after this works.

    The server still recognizes its LAN IP address as its own, yet I can look at it on the internet by going to the router's public ID. When I go to that address now, it says that the IP address is shared.

    I added myself as a client, and then added a site. I have two DNS numbers that will not go into my domain control panel. It says the TLD is not valid or something. And how do I get FTP access?

    EDIT: Is there a how-to guide on ISPConfig that's really good anywhere? I've looked through this website, and I just can't find one. I can follow along with a guide fairly well, and can even resolve some minor issues as they come up, but I'm a little lost/overwhelmed and feel like I'm wandering blind. Any advice or links to where I can find this would be very much appreciated.
    Last edited: Jul 8, 2006
  4. willebanks

    willebanks New Member

    Howdy StoddardIV,

    I too was having vast problems and was pointed here:

    Start with Admin and work down!

    It's kinda hard to follow unless you have 2 browser windows open and follow step by step with ISPConfig and the docs side by side...this worked for me yet I'm still a pain in the butt here asking all sorts of questions...but that is how I learn! Also don't be afraid to pitch in if you think you can help others, Till and falko really put in a lot of time and can use the extra help from us all!

    Also, You don't have to create a reseller to add can set them up as the admin! This had me a little stumped until I was again pointed in the right direction!
  5. StoddardIV

    StoddardIV ISPConfig Developer ISPConfig Developer

    I've read the manual, and it didn't help at all. I know what I'm asking may be more in-depth than anyone really cares to delve, but even just the first few steps should be enough to keep me more than occupied.

    I have the server set up behind a router in my office. The IP address on the LAN is different than the public IP address. The router automatically forwards all port queries on the public IP address to the server's LAN IP address. That's fine and good, and I can get to ISPConfig from home. I just don't know where to go from here.

    I have a website that I want to move to my server. The domain is with godaddy. The way I would assume one goes about changing what server a domain is pointing is changing the name servers. How do I make the nameservers point to my server? And then how do I create a site on the server that will be accessed when I type in the URL?

    Also, just another thing, and I do appreciate any help that I can get, I'm still not entirely sure of how this "hostname" and "domain" works on the server. In the router's set-up, those fields are blank. But ISP config demands that I put them in, so I put "www" in hostname and my domain name, call it, into domain. I'm not quite sure what this does. Again, any help at all is really appreciated.
  6. falko

    falko Super Moderator ISPConfig Developer

    Have a look here:

    You must type in an FQDN that points to your server. For example, you could get a address that points to your router's public IP address (if it is dynamic, otherwise you could get yourself a "real" domain), and then you can use this address as your server's hostname.
  7. StoddardIV

    StoddardIV ISPConfig Developer ISPConfig Developer

    Thanks for all of your help, guys. The website is now hosted on my own server, and that tutorial with the DNS from Godaddy really did it for me. I'm glad I had an extra comp. lying around. But I just have another question.

    I can get to the domain, and I get the whole "welcome blah blah blah" page generated by ISPConfig. But I can't get FTP to work (no matter what user name I put into the web-ftp login inside ISPConfig, it can't connect), webalizer doesn't work, and webmail doesn't work. I can make email addresses and stuff inside ISPConfig, but once I go to domain.tld/webmail it doesn't work. I tried looking in the ISPConfig manual, but it's just not working. I'm starting to think that perhaps these services aren't installed. Any help would be greatly appreciated.
  8. till

    till Super Moderator Staff Member ISPConfig Developer


    1) Did you check the FTP checkbox in the website.
    2) Did you create an (email) user, checked the administrator checkbox and used the username (web[ID]_user) to login with your FTP client?


    There is no such alias as domain.tld/webmail in ISPConfig.

    1) Install the uebimiau webmail addon.
    2) Use the URL: http(s)://
  9. StoddardIV

    StoddardIV ISPConfig Developer ISPConfig Developer

    FTP is enabled for the website, and a mail user has also been created. I thought that webmail was already installed in the ISPConfig set up? I have to install it myself? If that's the case, can someone tell me how to get the package with apt or wget?
  10. falko

    falko Super Moderator ISPConfig Developer

Share This Page