ispconfig wordpress and directory/file permissions

Discussion in 'Installation/Configuration' started by willebanks, Mar 5, 2010.

  1. willebanks

    willebanks New Member

    Howdy all,

    Got a weird problem that I'm hoping someone else has had and fixed.
    My Ubuntu 9.10 / ISPConfig installation went flawlessly.
    I setup 3 wordpress sites with no problems. The 4th site has driven me nuts.

    Here is the steps I used for all 4 sites...
    1. I downloaded the WordPress file into a "download" folder I created on the web server.
    2. I created each site via ISPConfig.
    3. Copied the WordPress file to the /var/www/web# folder of each site.
    4. Extracted (tar -xzvf) the WordPress file in the /var/www/web# folder of each site.
    5. Copied the /var/www/web#/web folder to /var/www/web#/webold and deleted the orignal "web" folder.
    6. Copied the /var/www/web#/wordpress folder to /var/www/web#/web
    7. Followed the WordPress "5 minute" install.

    I follow the above process for 4 sites. The first 3 sites went flawlessly. The forth site just wouldn't be "found" when I tried to browse to the site. After some head scratching I realized the I had elevated from my normal user to "super user" during the above process so all files and folder were owned by root...

    Rather than try to change all the files to the proper user, I deleted the "4th" site and as a "normal" user followed the above process again. Almost the same problem...all files and folders for the new site were "owned" by "www-data" and "www-data" is the group.

    On a hunch I reset the user password for the new site via ISPConfig. This changed the "owner" to the user but the group is still "www-data". The website now works but the user and group privileges are different from the user and group privileges for the other 3 sites. Example:
    -rwxrwxr-x "username" "web#" "filename" First 3 sites
    -rw-r--r-- "username" "www-data" "filename" Last 3 sites

    I have tried to install 2 others sites with the above process and still run into the "owner" & "group" problem. Something has changed but I don't know enough Linux to figure it out.

    I'm really sorry for such a long post but I want to give as much information as possible. If anyone can offer suggestions that would really make my day!

    Will Banks
  2. falko

    falko Super Moderator ISPConfig Developer

    What's your ISPConfig version?
  3. willebanks

    willebanks New Member

    Hi Falko,

    ISPConfig 2.2.35...hope this helps. I do have an adendum to my previous post.

    I deleted the problem website via ISPConfig and after a minute undeleted it. This seemed to fix the permissions problem but only to a point...some directories and files still showed root as owner.

    I found this out when I tried to install a new WordPress theme...WordPress was unable to create a new directory for the new theme. I had to do this manually...

    Will Banks
  4. falko

    falko Super Moderator ISPConfig Developer

    Did you create a user (on the "User & Email" tab) that has the "Administrator" checkbox checked?
  5. willebanks

    willebanks New Member

    Yes ...I did this for all the "users" which all have different variations of my name


Share This Page