ISPConfig2 causes duplicate entries in virtusertable

Discussion in 'General' started by Hans, Aug 10, 2009.

  1. Hans

    Hans Moderator ISPConfig Developer

    After executing postmap /etc/postfix/virtusertable that there where 3 duplicate entries within the virtusertable.db.
    So i opened the file virtusertable and i found out that the usernameA was valid for 3 different domains, like:

    [email protected] usernameA

    [email protected] usernameA

    [email protected] usernameA

    I removed the duplicate entries from the file virtusertable, but if a new mailuser has been added within ISPConfig, the duplicate entries appear again in the file virtusertable and virtusertable.db.
    This behaviour shows me that there must be something wrong with the ISPConfig2 database, but i can not find out what.
    Also within ISPConfig itself, i can not find anything related.

    Can anyone tell me what to do to solve this problem?
    Last edited: Aug 10, 2009
  2. Hans

    Hans Moderator ISPConfig Developer

    After a closer look, in ISPConfig2, i (finally) found 2 co-domains which do not belong to the main domain.
    I could delete one of these co-domains, however it never appeared in the Recycle bin.
    I also tried to delete the second co-domain as well, but then an error occurs, which says:

    "You do not have the necessary privileges to read or edit this entry."

    What can i do now to delete the second co-domain?
    Probably, i have to fix something within the db by using phpMyAdmin, but which entries do i have to delete?
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    There must be a duplicate entry in the isp_dep table which links the same co-domain to two websites.
  4. Hans

    Hans Moderator ISPConfig Developer

    Hi Till,
    within the isp_isp_domain table of the ISPConfig db, i found the following:

    doctype_id =1015
    domain_host=blank (no entry)

    This must be the co-domain, which i can't delete, because i recognize the domain name (domainA.tld) and the domain_host is blank (no entry), which is correct.
    This co-domain (domainA.tld) does not exists in ISPConfig itself (i checked everything) but it does in the db.

    I understand that within the isp_dep table:
    isp_isp_domain.doc_id = isp_dep.child_doc_id
    isp_isp_domain.doctype_id = isp_dep.child_doctype_id

    So, within the isp_dep table, i have to find the isp_dep.child_doc_id (=313) and the isp_dep.child_doctype_id (=1015). When i find it, i must delete the record containing this data from the isp_dep table...

    Can you confirm if that is correct Till? (Also please tell me if i am completely wrong)
    Is it necesarry to delete other records from any db tables as well?
    (i am very carefull as i don't want to screw my ISPConfig db!)

    Thanks for your feedback!
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Thats correct. Just delete the isp_isp_domain record and the corresponding isp_dep record(s).


    And make a backup of the db before you change something, just to be sure :)
  6. Hans

    Hans Moderator ISPConfig Developer

    Hi Till,

    Thanks for your confirmation!
    In the mean time i fixed it. :)

Share This Page