ispconfig3 and squirrel mail client

Discussion in 'General' started by afandino, Mar 15, 2010.

  1. afandino

    afandino New Member


    I know this has been asked a dozen times before but i have not been able to find a clear answer.

    Here is the scenario,

    the mail client is accessed through the main domain of the webserver and all the clients need to be directed there for webmail access. this is how it is now.

    What i need is for the client domain to have access to web mail at and not the main server domain.

    the other thing needed is for the address in the browser to show clientdomain/webmail, when i redirect the address bar shows the main domain/webmail

    Is there a way to make this happen that is clearly described ?

    thank you
  2. Toucan

    Toucan Member

    Have you thought about making an HTML file in that consists of a frame set? You can then load into the main body frame causing the original URL to be still displayed in the address bar?
  3. afandino

    afandino New Member

    I give that a try. Really had not considered that approach. I will let you know how it works out.

  4. tony_simcock

    tony_simcock New Member

    What I've done is have my webmail directory symlinked to all of my client domains... works for me...
  5. afandino

    afandino New Member

    Are you using ispconfig 3.02 ?
  6. tony_simcock

    tony_simcock New Member

    As of an hour ago - yes.
    Previously I was on

    if your webmail/ directory is in /var/www/ and your client's root web directory is in /var/www/clients/client1/client1web/
    then just type:
    ln -s /var/www/webmail/ /var/www/clients/client1/client1web/webmail
    Then when your client goes to they'll get the squirrel mail login screen
  7. Toucan

    Toucan Member

    Nice idea Tony, my idea of the frame really wasn't the most fancy solution. I don't have much understanding of symlinks so i might give it a try myself.

    Is this why I have duplicate contents of directories?

    is the same as

    Are symlinks used for that?

    Afandino, don't forget you can edit the way squirrel mail looks to make it more in keeping with your sites
  8. afandino

    afandino New Member

    I tried that and i get a page that says "No input file specified. "
    after i created the sym link. any ideas i have seen this before when i tried previously
  9. tony_simcock

    tony_simcock New Member

    Hi Afandino,
    What OS are you running on? if you do a ls -al in the directory you symlinked your webmail directory to, is webmail in a red block? can you access the content of the directory by following the symlink?
    eg. If you go from my example above, can you view the contents of /var/www/clients/client1/client1web/webmail ?
    if not, its possible the symlink hasn't worked. In which case if you do a pwd on the dir where your webmail dir is and tell me where you want it, I'll send you the command.

  10. afandino

    afandino New Member

    i'm running on debian 5.0, I had read else ware that symbolic links to web mail
    in ispconfig3.02 did not work correctly. I hope till or Falko could chime in here.

    tony i have not tried ls -al.

    the symbolic link i created did work in ftp i can view all the webmail files(not a good thing) I don't want my user to be able to see the contents of that directory for security reasons.

    thanks for your help
  11. tony_simcock

    tony_simcock New Member

    Ah right... Symbolic links shouldnt be an issue with ISPConfig 3, as they work fine on Centos 5.4.
    Ah, the security issue can be resolved by chmod'ing the webmail dir to root, then the user who ftp's in shouldn't be able to see the files (unless its root or has root privileges?)

    If the directory exists in what apache thinks is the document root for the request, then appending /webmail on the end should view its contents. Does apache have access to view the dir?
  12. afandino

    afandino New Member


    sorry for sounding stupid but where can i find the apache settings for that website.
  13. tony_simcock

    tony_simcock New Member

    Hi Afandino,
    On mine there are individual vhost files in /etc/httpd/conf/sites-available/ (if you using ISPConfig to administer your apache setup
    Failing that, the default conf file for apache is /etc/httpd/conf/httpd.conf then all the vhosts are defined at the bottom of the conf file.
  14. afandino

    afandino New Member

    I am trying to administrate through ispconfig3 . I have experienced in the past that if i try to alter settings outside of ispconfig things get all hosed up.
  15. tony_simcock

    tony_simcock New Member

    In that case just type:
    grep "DocumentRoot" /etc/httpd/conf/sites-enabled/yourwebsite.vhost
    Where yourwebsite is your website. :)
    That'll tell you where the webmail symlink needs to be.
    Last edited: Mar 19, 2010
  16. Meph

    Meph New Member

    Not sure if afandino was able to resolve this issue or not, but I'm having the same problem under Debian 5.0 with ISPConfig 3.

    I only have one SSL certificate that I use with my primary domain, so I want webmail to work by using https://www.domain.tld/webmail.

    Created the symlink as follows:

    ln -s /var/www/webmail/ /var/www/domain.tld/web/webmail

    When I run 'grep "DocumentRoot" /etc/apache2/conf.d/sites-enabled/domain.tld.vhost' I get:

    DocumentRoot /var/www/domain.tld/web
    DocumentRoot /var/www/domain.tld/web

    I have been looking around the web for a solution. One of them said to turn off cgi.force_redirect, but that didn't work. It was also suggested that I set a value for doc_root, but for obvious reasons that messes up my configuration. I'm under the impression that you are supposed to leave that blank when you are running virtual hosts, or maybe I just did it wrong.

    Unlike afandino I am not afraid to change settings outside of ISPConfig3. I've already disabled ClamAV. For some reason the built-in SSL certificate generator doesn't work through the ISPConfig3 control panel so I had to general my private key and CSR manually.

    Any suggestions?
  17. astewart

    astewart New Member

    After following the perfect Setup ispconfig 3 for your Linux distro, manually create an .vhost for your webmail.

    Eg, I am running ubuntu and my squirrelmail.vhost looks like this:
    This file resides in:

    But you will have to create a symlink to have it added to:

    (This is Ubuntu's Apache setup, unsure about other distros).

    Then just restart apache.

    All domains you host should be able to access webmail now:
  18. Meph

    Meph New Member

    Thank you, that worked. The file did not exist in sites-available though so I just created a new file in sites-enabled, and copied and pasted the example you posted.

Share This Page