ISPConfig3 FTP problem

Discussion in 'Server Operation' started by karazy-k, Aug 28, 2009.

  1. karazy-k

    karazy-k New Member

    To Whom It May Concern:
    I cannot access my web folders through FTP. This is upsetting, because I cannot upload my website.

    I recently wiped my server clean and installed ISPConfig3 fresh. ISPConfig3 is a bit different than ISPConfig2. In ISPConfig2 there was a web browser interface for FTP, though I could use an FTP client to connect too.

    In this new ISPConfig3 all I was able to do is create a site for a client and then create an FTP User. The only way I could see to connect to FTP was with a software like FireFTP, but I've had no luck. Trying to troubleshoot I discovered I can connect to ftp when connected to the server via ssh, but I cannot in any other fashion.

    When I use the program Fire-ftp in Firefox I get this:
    220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------
    220-You are user number 1 of 50 allowed.
    220-Local time is now 11:51. Server port: 21.
    220-This is a private system - No anonymous login
    220-IPv6 connections are also welcome on this server.
    220 You will be disconnected after 15 minutes of inactivity.
           USER kylekyle
    331 User kylekyle OK. Password required
           PASS (password not shown)
    230-User kylekyle has group access to: client1
    230 OK. Current restricted directory is /
           CWD /
    250 OK. Current directory is /
           TYPE A
    200 TYPE is now ASCII
    This just repeats over and over and over again. If I try using SecureFX it gives me an error and "terminates abnormally".

    I have pure-ftp installed.

    As an aside I am really Linux illiterate. As I understand it ISPConfig3 is a program that provides a web browser interface that manages the myriad of softwares necessary to create a web server, mail server, SQL database etc. I would prefer not to have to ssh to my server and mess around with things, because I am always worried I will change something and then ISPConfig3 will not recognize it.

    I cannot find a more straight forward way to host my own websites. I am just frustrated that I cannot learn how to fix these issues myself and therefore end up at these forums.

    Anyways, any help anyone can provide is greatly appreciated.
    Last edited: Aug 28, 2009
  2. falko

    falko Super Moderator ISPConfig Developer

    Have you tried both active and passive transfers in your FTP client? Could be a firewall issue.
  3. longvnit

    longvnit New Member

    Please give your messages
    Last edited by a moderator: Sep 1, 2009
  4. karazy-k

    karazy-k New Member

    Here is what my log says. It just keeps repeating. I'm not sure what is going on.
    Sep 01 09:35:16 proftpd[4153] ([::ff
    ff:]): FTP session opened.
    Sep 01 09:35:16 proftpd[4153] ([::ff
    ff:]): USER kylekarhohs: Login successful.
    Sep 01 09:35:17 proftpd[4153] ([::ff
    ff:]): FTP session closed.
  5. falko

    falko Super Moderator ISPConfig Developer

    What about my question?
  6. karazy-k

    karazy-k New Member

    Sorry about that Falko,
    I tried both active and passive and that did not fix it. I do not know if it is a firewall thing. I am not sure how to go about testing that. Thank you for your help.
  7. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    iptables -L

Share This Page