Ispconfig3 High availability cluster: mysql problem

Discussion in 'Installation/Configuration' started by stevegjacobs, May 12, 2010.

  1. stevegjacobs

    stevegjacobs New Member

    This is my second attempt to set up a high availability cluster with Ispconfig3. What I want is no single point of failure, so I have two separate servers, webserver1 and webserver2, set up with DRBD/Heartbeat.

    The first attempt was with Centos, which didn't work out due to problems with mail packages. I have started over with Debian. I have everything working on the Debian install, EXCEPT that when I force a failover, mysql won't start on webserver2.

    Here is what I have done:

    1. set up webserver1 and webserver2 with drbd/Heartbeat for clustering.
    2. Installed all packages and and Ispconfig on each server according to the 'Perfect server tutorial.
    3. Moved folders www, vmail, and mysql data folder from webserver1 to the drbd storage area (/mnt/drbd/ on my system)
    4. Created appropriate sym links and edited config files on each system to reflect the above changes.
    5. Started all services on webserver1, logged into ispconfig, added a website, installed Joomla on the site, added an email address and an extra ip address, and tested all. Everything worked!
    6. Forced a failover to webserver 2. Mysql won't start.

    The thing is, that when I first tried it on Centos, I did the same thing with everything, including mysql, everything worked except for mail. If I forced a failover, ispconfig, mysql, my websites and ip addresses all moved to webserver2. I gave up on Centos because I couldn't get mail to work on either server.

    Would anybody have any suggestions about what to do to get mysql to work?

  2. mike_p

    mike_p Member

    what information does mysqld.log give?
    (On centos its in /var/log - don't know where in your distro)
  3. stevegjacobs

    stevegjacobs New Member

    debian does things different

    Mysql logs are included in /var/log syslog. Here is the sequence of log entries when I try to start mysql:
    May 12 10:43:25 webserver2 mysqld_safe[1565]: started
    May 12 10:43:25 webserver2 mysqld[1568]: 100512 10:43:25 InnoDB: Operating system error number 13 in a file operation.
    May 12 10:43:25 webserver2 mysqld[1568]: InnoDB: The error means mysqld does not have the access rights to
    May 12 10:43:25 webserver2 mysqld[1568]: InnoDB: the directory.
    May 12 10:43:25 webserver2 mysqld[1568]: InnoDB: File name ./ibdata1
    May 12 10:43:25 webserver2 mysqld[1568]: InnoDB: File operation call: 'open'.
    May 12 10:43:25 webserver2 mysqld[1568]: InnoDB: Cannot continue operation.
    May 12 10:43:25 webserver2 mysqld_safe[1574]: ended
    May 12 10:43:39 webserver2 /etc/init.d/mysql[2128]: 0 processes alive and '/usr/bin/mysqladmin --defaults-file=/etc/mysql/debian.cnf ping' resulted in
    May 12 10:43:39 webserver2 /etc/init.d/mysql[2128]: #007/usr/bin/mysqladmin: connect to server at 'localhost' failed
    May 12 10:43:39 webserver2 /etc/init.d/mysql[2128]: error: 'Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)'
    May 12 10:43:39 webserver2 /etc/init.d/mysql[2128]: Check that mysqld is running and that the socket: '/var/run/mysqld/mysqld.sock' exists!

    I need to compare this to what happens when I restart on webserver1

Share This Page