ISPCONFIG3 with CenoS 7 two installs and no web, bind, mail etc.

Discussion in 'Installation/Configuration' started by vestport, Nov 3, 2014.

  1. vestport

    vestport Member

    Followed the perfect install for ISPCONFIG3 with CentOS7. Did 2 separate installs to make sure I wasn't going crazy and same results. I got to the point where ISPCONFIG3 was installed and then under "Monitor" nothing was working. Went to UBUNTU and everything installed and worked at least 95% but I really am more familiar with Centos and would rather run that. Has anyone else had this issue with the CentOS 7 install?

    Is this install how to getting updated soon?

    Thanks in advance for any replies

  2. srijan

    srijan New Member HowtoForge Supporter

    CentOS 7 perfect server is well tested and well prepared tutorial. There are no errors for ISPConfig.

    At which point you are getting error??

    Did you followed the tutorial word-word??
    Did you disabled the firewall as mentioned in the tutorial??
  3. vestport

    vestport Member

    I agree, you guys document this stuff very well. I love ISPCONFIG and CentOS! Been running them both for years. I just thought something may have been left out of the instructions by accident or one of the yum install files may have been offline temporarily and I missed the error with everything blowing by. The install post looked fairly recent (Oct 28, 2014) so I just wanted to ask in an effort to correct if there was an issue or save someone else losing days on this.

    Yes, followed word for word. To be specific, after minimal install and ssh I just ssh'd in and cut and paste all installs word for word other than instructions that needed to be edited manually with vi or nano. After the paste on multi line instructions I did hit enter to execute the last install command as well. After install I could login to ISPCONFIG but all the daemons under "Monitor" were red and not working. Several severe errors (at least a half dozen as I recall). I don't have the system intact still because I went to UBUNtU but will try this again on a different machine and follow up unless you have any ideas. I have been running CentOS forever so I really would rather use that as I am way more familiar with how it works. The only thing that I recall I needed to adjust during install was that one service was out of rev and I had to replace a .1 with a .2 to download.

    Any ideas?

    Thanks for your reply!

  4. till

    till Super Moderator Staff Member ISPConfig Developer

    I have a Centos 7 server here which is based on the published tutorial, all services are green and working fine, see attached screenshot.

    But personally I wont use Centos for a ISPConfig server, a server with Debian and Ubuntu has been proven to be more reliable on OS updates as yum tends to destroy config files from time to time which may bring your server down when you install updates with yum while apt from debain and ubuntu handles this smoothely.

    Attached Files:

  5. vestport

    vestport Member

    Resinstalled, all services now green but no DNS getting resolved.

    Here is report from



    I backed up named.conf and created a new named.conf as described:

    // named.conf
    // Provided by Red Hat bind package to configure the ISC BIND named(8) DNS
    // server as a caching only nameserver (as a localhost DNS resolver only).
    // See /usr/share/doc/bind*/sample/ for example named configuration files.
    options {
            listen-on port 53 { any; };
            listen-on-v6 port 53 { any; };
            directory       "/var/named";
            dump-file       "/var/named/data/cache_dump.db";
            statistics-file "/var/named/data/named_stats.txt";
            memstatistics-file "/var/named/data/named_mem_stats.txt";
            allow-query     { any; };
            allow-recursion {"none";};
            recursion no;
    logging {
            channel default_debug {
                    file "data/";
                    severity dynaic;
    zone "." IN {
            type hint;
            file "";
    and also did the:

    touch /etc/named.conf.local
    systemctl enable named.service
    systemctl start named.service
    Created "A"records for ns1 & ns2 and CNAME for pop3 and created website.

    When I dig @myipnumber nothing but refused, with no answer and no authority:

    ; <<>> DiG 9.9.4-RedHat-9.9.4-14.el7 <<>> @my.ip.num.ber
    ; (1 server found)
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: REFUSED, id: 8522
    ;; flags: qr rd; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 1
    ;; WARNING: recursion requested but not available
    ; EDNS: version: 0, flags:; udp: 4096
    ;               IN      A
    ;; Query time: 0 msec
    ;; SERVER: my.ip.num.ber#53(my.ip.num.ber)
    ;; WHEN: Wed Nov 05 09:19:08 EST 2014
    ;; MSG SIZE  rcvd: 44
    I'm stuck.

  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Login to ispconfig, go to system > server config > dns and set:

    bind_zonefiles_dir = /var/named
    named_conf_path = /etc/named.conf
    named_conf_local_path = /etc/named.conf.local

    then go to the dns module and change a value in the zone, e.g. ttl and click on save to apply it.
  7. Doug G

    Doug G Member HowtoForge Supporter

    The copy of the guide I used showed using init.d to start and enable pure-ftpd, bind, and also refered to using chkconfig. I simply substituted using systemctl instead.

    I just finished building a server with the centos7 guide, and ispconfig3 worked on first try, and monitor showed all services available.
  8. vestport

    vestport Member

    So sorry, I thought I replied earlier. The problem with DNS was the directories were not configured correct. Till's response solved the problem! Sincere thanks again Till!!!!!!!!!
    Also, thanks to everyone else who responded!!!!!

Share This Page