ispconfig_update not working after upgrading Ubuntu 18.04 to 20.04

Discussion in 'Installation/Configuration' started by BasAuer, Feb 8, 2023.

  1. BasAuer

    BasAuer New Member


    After upgrading my Ubuntu OS from 18.04 to 20..04 I wanted to run ispconfig_update.
    The script starts, but stops working after making the backups. No error or what so ever. ispconfig_update --force same. php -q installl from scipts directory is also a no go.

    • Ubuntu 20.04 LTS upgraded via do-release-upgrade
    • I run the script as root, not via sudo.
    • ISPConfig version 3.2.9p1
    • php 7.4
    • No dependencies missing (as far as i can tell).
    • It's a dedicated dns (secondary) server in our ISPConfig environment (4 machine) and is setup using all the steps from setting up ispconfig on ubuntu 18.04)
    I would be really helped if someone knows a solution. Or tell me where I can find/activate the logging.
    Thanks in advance.
  2. ahrasis

    ahrasis Well-Known Member HowtoForge Supporter

    You should first follow PST for Ubuntu 20.04 after upgrading to it. Then, if the script does not work, try downloading latest ISPConfig manually and attempt and update again.
  3. BasAuer

    BasAuer New Member

    Sorry, I don't know what you mean with PST?
  4. ahrasis

    ahrasis Well-Known Member HowtoForge Supporter

    Sorry, it is Perfect Server Tutorial.
    BasAuer likes this.
  5. BasAuer

    BasAuer New Member

    Sorry for the delay response.
    Thanks for the answer. But I have done that.

    Before doing the do_release I have don a full upgrade of Ubuntu 18.04, tested the script which worked.
    Then I did the do-relase upgrade to 20.04, followed all the steps in the pst which where nesarry, like all dependences etc. But the dependencies are all met.
    But the ispconfig_update script doesn't work any more.

    Maybe a strange observation..... I looks like it is MySQL which is the culprit. (Not sure because of the lack of logging).

    I'm going further with research and will update when I have a result.
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    It might be helpful if you run the test script and post the result:

    Sometimes, an upgrade with apt might remove mysql, at least I had this on Debian, so it might happen on Ubuntu too. In this case, it helps to install it again to get the system back in working order. That#s why @ahrasis suggested going through Ubuntu 20.04 perfect server guide step by step and rerunning the apt install commands, as this will install any packages that might be missing.
    ahrasis and BasAuer like this.
  7. BasAuer

    BasAuer New Member

    Sorry Till for not reading this thread. My bad.

Share This Page