Issue with auto installer - hangs on Bind9

Discussion in 'Installation/Configuration' started by Elayne, Oct 11, 2016.

  1. Elayne

    Elayne Member

    I've tried installing twice with the auto-installer and when it reaches the installation of Bind9 it just hangs, tried it twice and goes longer than 20 minutes ->

    If I however try running the auto installer again it goes well without any problems except for generating some errors with configuration of services. Any advise on how to proceed without errors?

    PS: Installing it on a VPS wtih Debian 8.
    Last edited: Oct 11, 2016
  2. Jesse Norell

    Jesse Norell Well-Known Member Staff Member Howtoforge Staff

    Just a guess, I've not tried the auto-install script, but maybe something is waiting for entropy? You could install haveged first and see if that resolves it (or if you are running in an openvz container, install haveged on the hardware node, not in your container).
  3. Elayne

    Elayne Member

    Unfortunately I've hired a VPS and cannot control the containers themselves any other suggestions? Yes it's an OpenVZ container.
  4. Jesse Norell

    Jesse Norell Well-Known Member Staff Member Howtoforge Staff

    The entropy issue is just a guess, but do check how much entropy you have available. See - you can try running haveged from the cli if it is an entropy problem, and/or ask your vps provider to install haveged on their hardware nodes (speeds some things in everyone's containers up, so just like running ntpd, they should run haveged or equivalent).
  5. Elayne

    Elayne Member

    So I've never heard about that before... so my guess is that this is what we are looking for, but I don't know if the number is good or not, I guess not as it wouldn't be failing ..:

    root@openvz2:~# cat /proc/sys/kernel/random/entropy_avail
  6. Elayne

    Elayne Member

    Right so here what I've found, perhaps this could be tried to get automated, it's finding a startup script of Bind.
    I ran the following: cat /var/log/apt/term.log

    Configuration file '/etc/init.d/bind9'
    ==> File on system created by you or by a script.
    ==> File also in package provided by package maintainer.
    What would you like to do about it ? Your options are:
    Y or I : install the package maintainer's version
    N or O : keep your currently-installed version
    D : show the differences between the versions
    Z : start a shell to examine the situation
    The default action is to keep your current version.
    *** bind9 (Y/I/N/O/D/Z) [default=N] ?


    So this is the latest message in all system logs and makes sense to make the installer hang. It's interesting though why when running the auto installer again everythin is going successful.

    By the way about the entropy, during the installation when it hanged again on Bind9, I've checked it again and it was 174, I've installed before the automatic script rng-tools supported with a guide from Falko so I guess that worked to increase it with around 40, but still doesn't resolve the installation issue.

    EDIT ============================= READ HERE!!!
    So I just pressed Y and Enter on blind and it continued to install, so the above is the issue and this is the solution, it's just not being displayed.
  7. Jesse Norell

    Jesse Norell Well-Known Member Staff Member Howtoforge Staff

Share This Page