Issues after MYSQL update

Discussion in 'Server Operation' started by Ovidiu, Sep 10, 2016.

  1. Ovidiu

    Ovidiu Active Member

    Running Debian8 according to the perfect setup for ISPCFG3 inside an LXC.
    Updated MYSQL from mysql-community (5.7.14-1debian8) jessie to mysql-community (5.7.15-1debian8) jessie

    During the start of MYSQL I see:
            Sep 10 12:34:38 alfred mysqld: Incorrect definition of table performance_schema.replication_connection_status: expected column 'RECEIVED_TRANSACTION_SET' at position 7 to have type longtext, found type text.
            Sep 10 12:34:38 alfred mysqld: Incorrect definition of table performance_schema.replication_group_member_stats: expected column 'COUNT_TRANSACTIONS_ROWS_VALIDATING' at position 6, found 'COUNT_TRANSACTIONS_VALIDATING'.
    MYSQL seems to be running fine but I'm worried about these lines. All I could find so far is this: which suggests:
    Not sure I should blindly follow that advice also, after doing /etc/init.d/mysql stop how would I start it with the --skip-grant-tables option?
  2. Use :

    service mysql start --skip-grant-tables
  3. Ovidiu

    Ovidiu Active Member

    thanks, seems to have worked :)
  4. baurmatt

    baurmatt New Member

    Srsly? This command lets MySQL just ignore the errors, it doesn't fix them! Please do not give answer to stuff you don't understand... Please try the following to actually fix the problem:

    This worked for my Percona Server 5.7 which through the same failures
  5. Ovidiu

    Ovidiu Active Member

    The answer was there, in the quote, sorry for not making it more obvious.
  6. Yep, answer was there and Ovidiu had issue with starting server with skip-grant. So I think both of us understand the things correctly here!

Share This Page