Issues with Installation - Attempting to Set Up ISPConfig with a separate mail server

Discussion in 'Installation/Configuration' started by Indieben, May 30, 2015.

  1. Indieben

    Indieben Member

    Hello, I'm a total newbie but I really want my mail server to be separate from ispconfig install for security and for stability purposes. My mail server is not up and running...yet and I am having one hell of a hard time with iredmail - are there alternatives with full SoGo integration i.e. Cardav/Caldav that will work with Thunderbird? A search of the web has not bought up much that is useful by way of an alternative. I am running CentOs 7, currently with the latest ISPConfig3 distro available from the ISPConfig website, I downloaded this about 2/3 days ago.

    There doesn't appear to be an IRC channel much to my amazement for ISPConfig software and I have absolutely no idea how to configure it for my needs. I am also unsure how to download the certificates it creates in order to be able to access services without restriction in the browser of another computer.

    Do I need to start again with my install and does anybody have a recommended plan of action?

    Many thanks,
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The ispconfig support is provided in this forum.

    Take a look at the installation tutorials list on the documentation page, there ser tutorials for single and multiserver setups available.

    Why dont you just install a free signed ssl cert instead if you dont want to receive warnings?
  3. Indieben

    Indieben Member

    Hi thanks for your message but i'm none the wiser as there does not appear to be a tutorial for simply having the Mail Server hosted on a separate box (I intend to use iredmail). I'd be grateful for any further pointers.

    Many thanks :)
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    We have one for a separate ispconfig mail server (see ispconfig multiserver tutorial). We dont have one for iredmail though as we are not the developers of that software. See:

    ISPConfig documentation page:

    and there the multiserver tutorials. E.g. this one explains hw to split a ispconfig system on several servers:
  5. Indieben

    Indieben Member

    Thanks for your reply :) I have tried this guide twice, although I am using Debian 7 Wheezy, I was advised that it shouldn't make all that much difference. I got to the part in the tutorial where I need to visit PHPMyAdmin and instead of going to that application, instead it is downloading a file in Mint (download (1) with the contents being:

    /* vim: set expandtab sw=4 ts=4 sts=4: */
    * forms frameset
    * @uses $GLOBALS['cfg']['QueryHistoryDB']
    * @uses $GLOBALS['cfg']['Server']['user']
    * @uses $GLOBALS['cfg']['DefaultTabServer'] as src for the mainframe

    So I'm not sure what's going on here :)

    Thanks and Kind Regards,

  6. till

    till Super Moderator Staff Member ISPConfig Developer

    This most likely means that you missde to enable the "apache" checkbox during phpmyadmin installation so that phpmyadmin is not configured. reconfigure phpmyadmin with the dpkg-reconfigure command and enable the apache checkbox this time.
  7. Indieben

    Indieben Member

    Hello, thanks for getting back to me so quickly - I was just going to bed after I messaged as i'd been up all night! I'm absolutely sure that I had enabled "Apache2" (appreciated not "Apache") (I followed the default options in the blue options screen). When I ran dpkg-reconfigure phpmyadmin, I was asked if I wanted to reinstall the database, I said no (just now) The box that was automatically populated was Apache 2, I selected OK and went back to my localip/phpmyadmin but it's made no difference. I still ended up with download (1) as a file being provided as a download rather than a webpage displayed! I would have liked to have done some Snaggy screenshots but as a newbie I think i'm unable to do this but I am totally stuck anyway :)
  8. Indieben

    Indieben Member

    Just an update - still not working:

    I have ensured PHP5 is installed, that it is enabled and loaded, that the phpmyadmin config is in the right place, that it is running and we tried enforcing that the php engine was On (followed by a restart of Apache2).

Share This Page