Jailkit installed after Ispconfig on slave server

Discussion in 'Installation/Configuration' started by gring, Jan 7, 2015.

  1. gring

    gring Member

    Hi !
    I tried installing Jailkit on a slave ispconfig server (running last version).
    After installing Jailkit, I manually ran an ispconfig update to reconfigure the services.

    Unfortunately I can't connect with ssh with a newly created user, because there is no command line interpreter, and the path to it is not set correctly.

    content of auth.log file :
    now entering jail /data/sites/clients/client7/web63 for user <username> (5007) with arguments
    ERROR: failed to execute shell /bin/bash for user <username> (5007), check the permissions and libraries of /data/sites/clients/client5/web68//bin/bash
    Received disconnect from <ip>: disconnected by user

    (note the /bin/bash appended on the site path).

    I tried creating a fresh site, and then a fresh chrooted user, but the only directories added in the site directory are :
    - etc (with an empty passwd file)
    - home

    I know it would work if a made a fresh install (Another identical server - the master ispconfig - where i installed jailkit before ispconfig works fine), but for the sake of learning I'd like to solve it.

    Which files should I look to see if ispconfig reconfigured jailkit ?

    Thanks !

Share This Page