jailkit problem with chroot

Discussion in 'General' started by snakeice, Mar 12, 2020.

  1. snakeice

    snakeice New Member

    Hi , i've made two server with ispconfig3, one with debian 9, one with debian 10.
    One client the day before yesterday asked me to have one shell account. hi data are stored on my debian 9 server . I've created a shell user under site and i've selected chroot=> jailkit.
    My client say that after he introduce the password, the shell crash. I've tried to set chroot=> none and he succeded in logging in, but he can acess to all filesystem.
    I tried to create a shell user on my debian 10 server and the user home directory display only his files.
    As my debian 10 is my personal web server used for developing and not for official server, do you know how to fix it on my debian 9 ? under monitor tab the sqare is green, not showing any problem apparently.
    zakjakub likes this.
  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Have you run the ISPConfig test script htf_report? What did it show?
    Create a jailed shell user for testing, and log in yourself. Monitor what logs show when you try logging in. Maybe try logging in with ssh client verbose turned on to see what is happening. For command line ssh client it is option -v, even more verbosity with -vv and -vvv.

Share This Page