Jobqueue locked

Discussion in 'ISPConfig 3 Priority Support' started by blackfox123, Mar 29, 2016.

  1. blackfox123

    blackfox123 Member

    Hi, Ive noticed the job queue is locked, upong investigating i run and get:

    locked because of many connection errors; unblock with 'mysqladmin flush-hosts'

    I have changed the max_connections to 1000 but this still is the case..

    I'm thinking there is a config file somewhere with an incorrect password in causing the host to get blocked?
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes, thats the most likely reason. Did you change the password of the "ispconfig" mysql user manually?
  3. blackfox123

    blackfox123 Member

    Hmm.. not that i remember, maybe a brain fart a while back when moving servers around though, how can i rectify/troubleshoot this?

    Is it the ispconfig config or individual services? The server is currently a slave server
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Both. The MySQL user with the name "ispconfig" is used by ispconfig itself and by postfix, amavis, pure-ftps and dovecot. You can try this:

    grep -r ispconfig /etc

    you can ignore the passwd, shadow, group and gshadow files. All other files that were found are most likely MySQL connection details.

    Does the local database locks or the external database on the master. If the master database locks, then the issue is the ispcsrv* user in one of the two ispconfig files (or any other connection from master to slave as this lock is not user specific, as far as I know).
  5. blackfox123

    blackfox123 Member

    I have tried resetting the ispconfig user in mysql password back to what is listed in /usr/local/ispconfig/server/lib/ (and restart server)

    Still no change..

    Not sure what has gone wrong
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Try to run a ispconfig update, choose reconfigure services during update. This will set the passwords in all config files again.
  7. blackfox123

    blackfox123 Member

    that did it.. i also forgot that the mysqladmin flush-host was to be executed on the master server too o_O

Share This Page