LAMP Installation On Ubuntu 6.06 For Linux Noobs - Startx problems

Discussion in 'HOWTO-Related Questions' started by Genin, Nov 12, 2006.

  1. Genin

    Genin New Member

    Greetings !

    [Please be advised that I am a Linux noob :) ]

    I downloaded the ubuntu server disc 6.06.1 (i386)

    I chose "Install LAMP Server", configured networkmanually etc etc
    and all this went smooth. After arriving at the prompt I entered:

    apt-get update

    apt get install ubuntu-desktop

    at the end I got two timeouts on files:

    and a suggestion to either run apt-get update or try with --fix-missing.

    I tried apt-get update since i ddin't know where to apply --fix-missing
    (should that be on apt-get install ubuntu-desktop ?)

    I didn't get to reboot system as it says in the howto so I did it anyway (reboot). When I run "startx" is says "unkown command" :-(

    Would like some instruction as to how to get x running, or to get some
    choice to choose kde/gnome/prompt as I had in my old Mandrake.

    Best regards, Genin
  2. sjau

    sjau Local Meanie Moderator

    What I've read in the Ubuntu Forum is that it's better to use aptitude for installing (alternate) desktops...

    So try the following:

    apt-get remove ubuntu-desktop
    apt-get update
    aptitutde install ubuntu-desktop
  3. Genin

    Genin New Member

    Thanks :) I'll try that and get back if it still wont work
  4. Genin

    Genin New Member

    Hi again !

    Unfortunatly it didn't work....

    First it couldn't be uninstalled because it wasn't installed (it said).

    Then I tried upgrade and aptitude for installing ubuntu-desktop

    It started good but at the end I first got some timeouts on some
    files and then it said that waiting for "hdc to accept command"
    for a few times and then some text of files flashed by and then
    I was at prompt again with "-startx no such command" :( :( :(

    Should it be so difficult to install a desktop on Ubuntu server???

    Greatful for any additional help since I dont wanna crawl back to
    W***ws Server 2003 etc etc.....
  5. sjau

    sjau Local Meanie Moderator

    no clue... hmmm, try

    apt-get --fix-missing

    Why do you want to install desktop on a server anyway?
  6. Genin

    Genin New Member

    apt-get --fix-missing, just scroll the options for the command by
    like I had used it wrong.

    I want a graphical environment because I find it smoother than
    punching in long commandstrings. Also I want to run Azureus and
    Valknut on the server and they need a graphical environment.

    I am still amazed that it is so difficult to obtain something so basic
    in Linux still...

    Anyway as before I am greatful for any help that I can get :D
  7. sjau

    sjau Local Meanie Moderator

    well, if you want to operate a desktop I rather recommend you installing the Desktop version and then add apache and stuff...

    Well, if apt-get --fix-missing scrolls the options for the command then you also have in the first a line a syntax on how to use it. :)
  8. Genin

    Genin New Member

    Woohooo :D

    By running "apt-get install kubuntu-desktop" I am now sitting at the server
    in a nice KDE environment ;)
    So that little k infrontof ubuntu-desktop made it better.

    Now for another wonderful desktop question:

    When I start X and KDE "kicks in" it is set to 1280x1024 60Hz.
    I would like that to be 1024x768 85Hz and I suppose there must
    be some little config file somewhere that controls this.
    But where can I find it and what is the name of it?
    (This is prior to logging on because then it uses my desktop settings
    which is 1024x768 85Hz.)

    Thanks In Advance - Genin (Your typical average annoying LinuxNoob:) )
  9. falko

    falko Super Moderator Howtoforge Staff

    I'm not quite sure, but maybe xorg.conf? You can search for such a file by running
    locate xorg.conf
  10. Genin

    Genin New Member

    Yes I found the xorg.conf and to my bliss Nano was already installed :)
    I couldn't find any entry that forced the default login screen to 1280x1024.
    I found "DefaultDepth 24" which is colordepth but no line for "Default Mode".
    I found a line listing modes like : Modes "1280x1024" "1024x768" "832x624" "800x600".....etc
    But I dont know if I could delete the "1280x1024" part or make a new
    entry under "DefaultDepth 24" saying 'Default mode 1024x768' ?

    Any ideas?

    Best Regards, Genin
  11. sjau

    sjau Local Meanie Moderator

    you could try to reconfiger your xserver:

    sudo dpkg-reconfigure xserver
  12. Genin

    Genin New Member

    Hmm I tried it and it answered:

    Package `xserver' is not installed and no info is available.
    Use dpkg --info (= dpkg-deb --info) to examine archive files,
    and dpkg --contents (= dpkg-deb --contents) to list their contents.
    /usr/sbin/dpkg-reconfigure: xserver is not installed

    I also read through the man for xorg.conf but I couldn't find any ways to
    set startup screen to less than 1280x1024...

    Uhm, another thing I have a question about ark and path, perhaps I should start another thread? Cause don't know if it still goes under "How to questions?"

    Best Regards, Genin

Share This Page