latest debian mysql update error

Discussion in 'General' started by orasis, Jul 22, 2014.

  1. orasis

    orasis Member

    Hi i would like some help on this in order to return mysql back.
    This is a debian wheezy x64 server with ispconfig3.
    I just installed the latest updates and it messed up. please see:

    # apt-get upgrade
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    The following packages will be upgraded:
      acpi-support-base libmysqlclient-dev libmysqlclient18 mysql-client mysql-client-5.5 mysql-common mysql-server mysql-server-5.5 mysql-server-core-5.5
    9 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    Need to get 9,645 kB of archives.
    After this operation, 29.7 kB disk space will be freed.
    Do you want to continue [Y/n]? y
    Get:1 wheezy/updates/main mysql-common all 5.5.38-0+wheezy1 [78.6 kB]
    Get:2 wheezy/updates/main mysql-server all 5.5.38-0+wheezy1 [76.9 kB]
    Get:3 wheezy/updates/main mysql-server-5.5 amd64 5.5.38-0+wheezy1 [2,098 kB]
    Get:4 wheezy/updates/main mysql-client all 5.5.38-0+wheezy1 [76.7 kB]
    Get:5 wheezy/updates/main mysql-client-5.5 amd64 5.5.38-0+wheezy1 [1,886 kB]
    Get:6 wheezy/updates/main mysql-server-core-5.5 amd64 5.5.38-0+wheezy1 [3,777 kB]
    Get:7 wheezy/updates/main libmysqlclient-dev amd64 5.5.38-0+wheezy1 [948 kB]                                                                          
    Get:8 wheezy/updates/main libmysqlclient18 amd64 5.5.38-0+wheezy1 [680 kB]                                                                            
    Get:9 wheezy/updates/main acpi-support-base all 0.140-5+deb7u1 [22.8 kB]                                                                              
    Fetched 9,645 kB in 10s (952 kB/s)                                                                                                                                                
    Reading changelogs... Done
    Preconfiguring packages ...
    (Reading database ... 58762 files and directories currently installed.)
    Preparing to replace mysql-common 5.5.37-0+wheezy1 (using .../mysql-common_5.5.38-0+wheezy1_all.deb) ...
    Unpacking replacement mysql-common ...
    Preparing to replace mysql-server 5.5.37-0+wheezy1 (using .../mysql-server_5.5.38-0+wheezy1_all.deb) ...
    Unpacking replacement mysql-server ...
    Setting up mysql-common (5.5.38-0+wheezy1) ...
    (Reading database ... 58762 files and directories currently installed.)
    Preparing to replace mysql-server-5.5 5.5.37-0+wheezy1 (using .../mysql-server-5.5_5.5.38-0+wheezy1_amd64.deb) ...
    [ ok ] Stopping MySQL database server: mysqld.
    [ ok ] Stopping MySQL database server: mysqld.
    Unpacking replacement mysql-server-5.5 ...
    Preparing to replace mysql-client 5.5.37-0+wheezy1 (using .../mysql-client_5.5.38-0+wheezy1_all.deb) ...
    Unpacking replacement mysql-client ...
    Preparing to replace mysql-client-5.5 5.5.37-0+wheezy1 (using .../mysql-client-5.5_5.5.38-0+wheezy1_amd64.deb) ...
    Unpacking replacement mysql-client-5.5 ...
    Preparing to replace mysql-server-core-5.5 5.5.37-0+wheezy1 (using .../mysql-server-core-5.5_5.5.38-0+wheezy1_amd64.deb) ...
    Unpacking replacement mysql-server-core-5.5 ...
    Preparing to replace libmysqlclient-dev 5.5.37-0+wheezy1 (using .../libmysqlclient-dev_5.5.38-0+wheezy1_amd64.deb) ...
    Unpacking replacement libmysqlclient-dev ...
    Preparing to replace libmysqlclient18:amd64 5.5.37-0+wheezy1 (using .../libmysqlclient18_5.5.38-0+wheezy1_amd64.deb) ...
    Unpacking replacement libmysqlclient18:amd64 ...
    Preparing to replace acpi-support-base 0.140-5 (using .../acpi-support-base_0.140-5+deb7u1_all.deb) ...
    Unpacking replacement acpi-support-base ...
    Processing triggers for man-db ...
    Setting up mysql-client-5.5 (5.5.38-0+wheezy1) ...
    Setting up mysql-server-core-5.5 (5.5.38-0+wheezy1) ...
    Setting up mysql-server-5.5 (5.5.38-0+wheezy1) ...
    [ ok ] Stopping MySQL database server: mysqld.
    [FAIL] Starting MySQL database server: mysqld . . . . . . . . . . . . . . failed!
    invoke-rc.d: initscript mysql, action "start" failed.
    dpkg: error processing mysql-server-5.5 (--configure):
     subprocess installed post-installation script returned error exit status 1
    dpkg: dependency problems prevent configuration of mysql-server:
     mysql-server depends on mysql-server-5.5; however:
      Package mysql-server-5.5 is not configured yet.
    dpkg: error processing mysql-server (--configure):
     dependency problems - leaving unconfigured
    Setting up mysql-client (5.5.38-0+wheezy1) ...
    Setting up libmysqlclient18:amd64 (5.5.38-0+wheezy1) ...
    Setting up libmysqlclient-dev (5.5.38-0+wheezy1) ...
    Setting up acpi-support-base (0.140-5+deb7u1) ...
    Errors were encountered while processing:
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    any help appreciated, thank you.
  2. Turbanator

    Turbanator Member HowtoForge Supporter

  3. orasis

    orasis Member

    Turbanator, many thanks for your reply, I was trying to avoid removing mysql so I kept looking for solutions but nothing worked.

    Finally I had the idea to put back the original my.cnf once I have been using the my-huge.cnf previously, so it worked, mysql came back. Looks like there were some changes in this file maybe. I then used again the /usr/share/doc/mysql-server-5.5/examples/my-huge.cnf.gz to extract my-huge.cnf and replace my.cnf once again and it looks like there is no problem now.

    Now all I worry is if there is something left undone due to this error there.
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    It can happen that mysql does not start if the my.cnf file changed. DEbian will not change that file on normal package updates, so it might be that the file was changed before without rebooting mysql so that the issue just camme up as coincident with the update? Just a guess :) As I update all my debian servers for years incl. the update that you did now and never hat a problem, even with a modified my.cnf.
    Basically you should have found errors in the syslog during mysql startup about this errors.

    I think it should be fixed now.
  5. orasis

    orasis Member

    Thanks till, this was the 1st update that stressed me on this machine so far, fortunately the solution was easy. As I take care of this server alot, I found it weird that my dev machine that uses the original my.cnf updated without errors, that gave me the idea that the cause might be that.

    It was strange what happened ... :)

    State: ok (0 unknown, 0 info, 0 warning, 0 critical, 0 error)
    thanks once again.

Share This Page