Let's Encrypt and 3.1rc1

Discussion in 'General' started by RootEtsy, Aug 11, 2016.

  1. RootEtsy

    RootEtsy New Member

    Hi all,

    I'm testing out version 3.1 and I'm not sure if I'm missing something or not but I can't find the option to create an SSL certificate with Let's encrypt. I only see the standard SSL stuff in the SSL tab.

    I have the option for the site checked that says "Let's Encrypt SSL". It's underneath the SSL option. Both are checked.

    Also, I do actually have the certbot installed per the installation guide.

    So how do I actually create a new lets encrypt cert? :)
  2. RootEtsy

    RootEtsy New Member

    OK it appears to create the certificate automatically I'm guess. Looking in /etc/letsencrypt I can see the certificate but it isn't installing in the apache vhost.

    Is there something I've done incorrectly?
  3. till

    till Super Moderator Staff Member ISPConfig Developer

  4. RootEtsy

    RootEtsy New Member

    Hi Till,

    Many thanks for the response, that is some great information!

    With this I was able to figure out what was happening. I'm not exactly sure why it happened but it's fixed now. I'll explain what I saw and how I fixed so if anyone else is seeing this they can too. :)

    So when I ran the server script it would run the letsencrypt script with no issues. It would say it was writing the new vhost file and restart apache. No issues were reported at all. Weird.

    Looking in the letsencrypt storage location, I saw the certs and keys, etc. I decoded these using the tools at sslshopper.com. No issues with them.

    So I just removed them from the following.

    Then did it again and it worked like a charm!

    I'm thinking maybe what caused the whole thing to freak out was what I did when I initially set it up. I didn't understand that just checking the letsencrypt check mark was going to do all the work. I had checked the check mark and then went to the SSL tab and did a create. So it did this at the same time and I guess caused an issue. Lol.

    Anyway, many thanks for the help with debugging info. I'll certainly be using that any time there is an issue. :)
    cassola-enterprises likes this.

Share This Page