Let's Encrypt doing nothing - 3.1.3/4

Discussion in 'General' started by ChildOTK, Jun 21, 2017.

  1. ChildOTK

    ChildOTK New Member

    Good Evening,
    A couple days ago I setup a new Debian 8.8 64-Bit with a brand new install and setting up ISPConfig from The Perfect Server setup for Apache and ISPConfig. Everything seemed fine and everything is working fine except for the Let's Encrypt Mechanism.

    When I enable SSL and select Let's Encrypt, in the past this just worked and I have never had any trouble. This time however for the new server, there is the little red circle at the top showing the new pending task, it takes abnormally long but goes away. When I go back to the domain settings, SSL and Let's Encrypt are unchecked, and looking at /etc/letsencrypt/live/, there are no files for the domain.

    I cannot find anything in the logs either, which is very strange. It just seems to not be doing anything at all. If I manually run /opt/certbot/certbot-auto, it doesn't install anything new, but lists the domains I have added in ISPConfig. I can manually install a SSL Certificate using this command line client. But the ISPConfig UI simply doesn't do anything. This is the first server I have experienced this issue with.

    I updated ISPConfig today to the new 3.1.4 update, same behavior.

    I also tried installing certbot using the new Debian 9 way:

    sudo apt-get install python-certbot -t jessie-backports
    No difference.

    Does anybody have any ideas?

    Thank you for your help!
  2. sjau

    sjau Local Meanie Moderator

    is your server behind NAT?
  3. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    You can check under /etc/letsencrypt/live/ and see if certificates have been issued; if so, maybe you have a website .err file being generated, so the problem isn't letsencrypt, but rather reconfiguring your web server to use the certificates.

    There's nothing in /var/log/letsencrypt.log? Check the letsencrypt error faq (in particular make sure DNS is setup for all names in the certificate).

Share This Page