Let's encrypt with ISPConfig 3.1

Discussion in 'General' started by alexandernst, Sep 28, 2016.

  1. alexandernst

    alexandernst New Member

    I just installed ISPConfig 3.1 and I tried to enable the Let's Encrypt checkbox in one of my websites, but after saving the changes, waiting for a few minutes and then getting back to the settings, I realized the checkbox was unchecked again and there were no SSL certs.

    Is there something else that I must do in order to get a cert from Let's Encrypt?
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The checkbox get unchecked when letsencryp as not able to issue a cert. Try to enable it again, if it fails again, use the debug mode to see why letsencrypt fails. common reasons are DNS misconfigurations, missing subdomains in DNS or redirections of domains or subdomains which avoid that letsencrypt finds its token.
  3. fisik

    fisik New Member

    don't want to create new thread about LE so sorry that I post here.
    I just updated to 3.1 and I would like to ask, how LE works because I did not find any information about this
    - does ISPconfig check expiration of certificates and auto-renew them? Or when certificate will expire do I need just to check the box and save?

  4. Jesse Norell

    Jesse Norell Well-Known Member Staff Member Howtoforge Staff

    Yes, they will be automatically renewed.
  5. Mef-isp

    Mef-isp New Member

    I hope someone knows this..

    I installed ispconfig 3.1dev using perfect server ubuntu 16 Xenial, apache 2.4. All works fine, but Let's encrypt does not.
    I read: https://www.howtoforge.com/community/threads/lets-encrypt-error-faq.74179/

    In the LE log files I find: (replaced username by <username>:
    File "/home/<username>/.local/share/letsencrypt/bin/letsencrypt", line 11, in <module>
    File "/home/<username>/.local/share/letsencrypt/local/lib/python2.7/site-packages/certbot/main.py", line 776, in main
    return config.func(config, plugins)
    File "/home/<username>/.local/share/letsencrypt/local/lib/python2.7/site-packages/certbot/main.py", line 506, in run
    domains = _find_domains(config, installer)
    File "/home/<username>/.local/share/letsencrypt/local/lib/python2.7/site-packages/certbot/main.py", line 273, in _find_domains
    raise errors.Error("Please specify --domains, or --installer that "
    Error: Please specify --domains, or --installer that will help in domain names autodiscovery

    I updated Ispconfig using git-stable but that did not help, I searched but could not find this sort of log.

    I checked the DNS and I have CNAME www for the domain enabled. I have No redirects.
    When I acticate certbots-auto I see a listing of the domain names and the www ones. I choose Cancel as I want ispconfig to handle LE.

    I ran out of options, what can I do?
    Last edited: Oct 10, 2016

Share This Page