Lets Encrypt - wont renew

Discussion in 'General' started by cassola-enterprises, Nov 21, 2016.

  1. Hi,

    I had a website with a domain.tld.
    I deleted the webspace and then made another one with the same domain name.
    Now Lets Encrypt wont renew.
    It might have been also an issue before deleting the first websapce where it worked.
    Manual forced renewal also doesnt work because a vhost cant be found although it exists in ispconfig.

    Any help will be appreciated.
  2. sjau

    sjau Local Meanie Moderator

    well, the certs and stuff are by default stored in /etc/letsencrypt - not sure if ISPC does that also. You could go in there and remove the previous domain info from the live and archive folders.
    cassola-enterprises likes this.
  3. Thank you very much! That did the trick!
    @till would you consider adding a feature that would allow one to delete the according folders from ISPconfig?
    Or to automatically do that once you delete a website that has letsencrypt enabled?
    I ran into some problems trying to make the same site again with the same domain and certificate.
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    The ssl certs get not removed by ispconfig as it is possible that you use the cert in another service that ispconfig is not aware of and this service would fail if ispconfig removes the cert.
  5. Would you consider adding a function to deliberately and manually (pressing a button in a special section) deleting the folders if one is shure that they are not needed by any other services? Would be more convenient then having to go into the command line.
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Sure. Make a feature request in the bugtracker.

Share This Page