Letsencrypt - I think I screwed it up

Discussion in 'Installation/Configuration' started by Curtis Maurand, Aug 27, 2017.

  1. Greetings,
    It's a beautiful late summer day here in Maine. Here I sit struggling with migration issues. I won't go into the gory details of what an ill conceived first attempt that went irretrevably wrong. So wong that it left both ends of the system broken. So broken that I deleted the original virtual machine that I was going to and started over with a fresh install of Ubuntu 16.04 and followed the perfect server guide. I didn't run any letsencrypt commands for the first couple of days, but letsencrypt was on the machine and running for a couple of days. I checked through log files and .bash_history files to see if any letsencrypt commands had been run. The answer is no. I hadn't run letsencrypt at all. I'm hoping that's a good thing. I saw in one forum that letsencrypt-auto needed to be run and no questions answered or letsencrypt-auto --help and only then would letsencrypt work properly with ispconfig.

    I have a snapshot of my server at that point. There are a couple of websites installed, but I hadn't tried to sign any of them.

    Roll forward 2 weeks to today and I've been working on trying to migrate web sites one at a time and rebuilding the control panel and all my customers 1 by 1. Not a huge job, but tedious and time consuming.

    letsencrypt wasn't working. in attempts to get it working, I ran letsencrypt --standalone (which ran successfully)... and I'm feeling that may have rendered letsencrypt unusable with ispconfig permanently. So I'm pretty sure I've screwed this one up irretrievably Someone please tell me if I'm wrong.

    So the question is this: Should I revert this server back to the snapshot and run letsencrypt --help and copy the user folders back in, restore a database dump or punt and start over from my clean install snapshot (ubuntu before perfect server install) and start my builds all over again. It won't break my heart to start again. I have had to start each of these things 3 times to get it right. This would be the 3rd iteration coming. Time is of the essence here. I don't want to spend days trying to fix something if starting from near scratch with a fresh ubuntu install might be faster. I've got the creating of the accounts and copyting data over down to a science. I'm only at the mercy of cron.

    Thanks in advance,
    Curtis Maurand
    Xyonet Web Hosting
  2. sjau

    sjau Local Meanie Moderator

    removing all of /etc/letsencrypt and then running it once with --help should fix the things I think.
  3. Thank you. That worked. signed a zone right away. I was going back over "The Perfect Server" guide and I noticed that the "letsencrypt --help" step is not there, but I don't know if it's required, either.

    Again, thank you for your help.
  4. sjau

    sjau Local Meanie Moderator

    well, certbot/letsencrypt has changed.... over time and the howtos are just a snapshot of the time when written.... there were instances where --help caused problems.

Share This Page