LetsEncrypt problem on Upgraded ISPConfig

Discussion in 'Installation/Configuration' started by mislav, Apr 5, 2017.

  1. mislav

    mislav Member

    Hi there.

    - Linux Distribution and version used on your server. - debian 8
    - ISPconfig version - 3.1.2

    I've noticed the following problem:
    First of all, this happens ONLY when I upgrade ispconfig from to 3.1.x - clean installations 3.1 don't have such problem. What I've also noticed is that inside of ispconfig.conf there were few lines missing:
    I've added that and I'm still not able to generate letsencrypt SSL from Ispconfig. Manually, command line I can - so it's definitely some kind of ispconfig related problem. What to do/how to fix it?
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Did you choose yes when the updater asked to reconfigure services? As this will add the lines that you were missing. If you use any custom templates for vhosts or the ispconfig.conf file, then these ned to be changed for the new ispconfig version as well as LE won't work with templates from older versions. And you might hate to run Tools > resync on all websites once so they get the new config file template.
  3. mislav

    mislav Member

    Now that I think of, I said no to reconfigure services (I've a lot of custom settings in dovecot/postfix/etc) and I didn't want to lose changes (as I did few times).
    Is there any way to run now manually this reconfigure services OR I must wait for minor update and do it then (I will make then backup of etc so it's safe to reconfigure).
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Leaving out reconfigure services on minor updates like 3.1.1 to 3.1.2 is ok, but major updates like 3.0.5 to 3.1 require it, otherwise most of the new features wont work.

    cd /tmp
    wget http://www.ispconfig.org/downloads/ISPConfig-3.1.2.tar.gz
    tar xvfz ISPConfig-3.1.2.tar.gz
    cd ispconfig3_install/install
    php -q update.php
    mislav likes this.
  5. mislav

    mislav Member

    Works like a charm. Noted for the future and thank you very much! Letsencrypt works now through ispconfig / deletion as well.

Share This Page