locating named.conf failed

Discussion in 'Server Operation' started by stoa05, Feb 27, 2008.

  1. stoa05

    stoa05 New Member

    running CentOS 5.1, I am unable to start named. I did a yum install of:

    I did chkconfig --levels 35 named on
    I tried: service named start
    and I get the error:
    [[email protected] named]# service named start
    Locating //etc/named.conf failed: [FAILED]

    First thing I noticed is the double forward slashes //etc - this must be a mistake, but how did it happen and how do I correct it.

    If I do: ls -la /etc | grep -i bind
    nothing is returned, thus named.conf does not exist, but how can this be?
    Does it matter that I was in X in a terminal when I did the yum install?

    I tried to get some information by debugging:
    I did /etc/init.d/named -d 1
    and I got the file named.run:
    cat named.run
    27-Feb-2008 02:57:43.829 starting BIND 9.3.3rc2 -d 1
    27-Feb-2008 02:57:43.832 found 1 CPU, using 1 worker thread
    27-Feb-2008 02:57:44.021 loading configuration from '/etc/named.conf'
    27-Feb-2008 02:57:44.024 none:0: open: /etc/named.conf: file not found
    27-Feb-2008 02:57:44.034 load_configuration: file not found
    27-Feb-2008 02:57:44.035 loading configuration: file not found
    27-Feb-2008 02:57:44.035 exiting (due to fatal error)

    I don't know what to try next. Any help is gratefully accepted.
  2. cooljai

    cooljai New Member

Share This Page