Loop in Migration tool

Discussion in 'Plugins/Modules/Addons' started by Andreas G., Apr 5, 2023.

  1. Andreas G.

    Andreas G. New Member


    I have a problem with the migration tool. When trying to do a try run it loops here:

    What is the ip for the target web server to connect via SSH? [xxx.xxx.xxx.xx]:
    What is the SSH port? [22]:

    Now we transfer the key to the target server.
    /usr/bin/ssh-copy-id: INFO: attempting to log in with the new key(s), to filter out any that are already installed
    /usr/bin/ssh-copy-id: INFO: 1 key(s) remain to be installed -- if you are prompted now it is to install the new keys

    Number of key(s) added: 1

    Now try logging into the machine, with: "ssh -p '22' -o 'StrictHostKeyChecking=no' -o 'ConnectTimeout=5' '[email protected]'"
    and check to make sure that only the key(s) you wanted were added.

    What is the ip for the target web server to connect via SSH? [xxx.xxx.xxx.xxx]:

    Any Idea what could be wrong?
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    This happens in the backgound: a new ssh key is generated, and this key is then copied to the new server using the ssh copy id command, then the tool checks if the login works now. So basically this means that your old server cannot do a successful key-based SSH login on the new system.

    Try adding:

    PubkeyAcceptedAlgorithms +ssh-rsa
    in the /etc/ssh/sshd_config file on the new system, restart ssh on the new system. Stop migration tool (e.g. with ctrl + c), then start migration tool again to see if it works now.
    ahrasis likes this.

Share This Page