Losing time...

Discussion in 'Installation/Configuration' started by cic, Sep 20, 2007.

  1. cic

    cic New Member

    My ISPConfig virtual appliance seems to be loosing time every day. I reset the time yesterday around 10PM and it has already lost approximately 6 hours. I've tried NTP as well as just hard setting the date/time and neither seems to work. Does anyone have any idea how to fix this?

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    What you describe is a common problem with vmware. You could either install the vmware tools, which should fix the problem or you sync the clock with NTP automatically.

    Does the clock gets synced when you run:

    ntpdate pool.ntp.org
  3. cic

    cic New Member

    I have never installed the vmware tools on a linux box. Can you point me in the right direction on this?

    No, when I run ntpdate pool.ntp.org, I get the following message: the NTP socket is in use, exiting

    Any ideas?
  4. falko

    falko Super Moderator ISPConfig Developer

    This means that ntpdate is already running.

    Oliver is currently writing a tutorial about installing VMware Tools on various distributions. It will be published in a few days, I think. :)
  5. rachel

    rachel New Member

    I believe it's a specific problem when VMWare is running on a Linux host with an AMD processor; it's an issue with the timing calibration being messed up by powernowd. Certainly, for instance, there's no such issue with a VM running in VMWare Fusion on a mac host.

    Installing VMWare Tools is the solution; and once you've installed it you need to run the vmware-toolbox in order to actually turn on RTC synchronisation. The VMWare Toolbox is an X application, so you'll need to supply its minimal X11 dependencies so you can run it through a tunnelled X. (xauth, libXi, libX11)

    I've had little luck using ntp to keep the clock right; an ntpdate command in a cronjob running every *minute* made it not too bad (but you do need ntpd to be disabled or you get the error you've been getting, I think).

    Installing VMWare Tools can be a bit distro-specific. It's even so eccentric on Gentoo that I included an off-topic mini-howto on doing it on Gentoo in my Perfect Setup howto for that distro. Others, for instance, Ubuntu, are far more straightforward, being supported by VMWare directly.

    (Of course I note the original poster didn't specify it was a *VMWare* virtual machine... :-}

Share This Page