lost ispconfig admin password

Discussion in 'Installation/Configuration' started by adrenalinic, Jan 10, 2008.

  1. adrenalinic

    adrenalinic Member


    i have lost admin password of ispconfig admin.
    i not have phpmyadmin installed for change it fast!

    how can change it?
    there is a .ini file where I can change it?

    very thanks!
    help help!
  2. till

    till Super Moderator Staff Member ISPConfig Developer

  3. emdok

    emdok New Member

    I've a similar problem where ispconfig will create a database in the admin panel but it does not actually show up in mysql, which basically the new database is not being created I suppose I'm also unable to run updates because of it. When I run ispconfig_update.php an error stating it could not log on as [email protected]

    If I use
    mysql -uroot -ppassword
    I can log on to mysql as root.

    I've tried setting /usr/local/ispconfig/server/lib/conf.inc.php
    and entering the root user and password (since I do not know what the password of the ispconfig user in mysql is) under the section //** Database
    I do not think that worked.

    The hostname of the box was also changed but here's the output of:

    hostname -f
    hostname: Unknown host
    I have had to reset the admin user to get into ispconfig's admin panel. The login does work.

    not sure if that is related to the mysql issue. This is ISPConfig 3.0.16 on CentOS. Any thoughts?
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    you posted here in a thread about ispconfig 2, which is a completely different softeware theasn ispconfig 3. So nothing that you read here applies to your server.

    Putting the root user in the config.inc.php file on a ispconfig 3 server breaks the system if you try to update then, so you have to undo that and restore the exact user and password that was in the file.

    regarding your original problem, you must have changed the root password in mysql and missed to change it afterwards in the mysql_client.inc.php file in /usr/local/ispconfig/server/lib/
  5. emdok

    emdok New Member

    I apologize for posting in the wrong section, I arrived here from a google search. If I develop more questions I will create a new post or find a post similar to the issue I experience in the correct section.

    I did indeed miss changing it in the mysql_client.inc.php
    Thank you very much for the quick response.

Share This Page