Mail Filter Problems

Discussion in 'Installation/Configuration' started by chicken12, Apr 10, 2010.

  1. chicken12

    chicken12 New Member

    Hi, I followed the perfect server guide for ISP Config 3 and CentOS 5.4. Everything seems to be working great except the mail filtering rules in ISPConfig. I checked on each of the mail boxes the "Move Spam Emails to Junk directory" but it is not working. So I figured I would create a rule with the Subject of ***SPAM*** and move to junk and it is still not working. Any pointers on where to start troubleshooting this? Thanks!!
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Are the spam emails tagged in the subject with ***SPAM*** ?
  3. chicken12

    chicken12 New Member

    yes. The spam software is working fine. Its just the mail filtering rules are not working right. Thanks
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Which ispconfig version?
  5. chicken12

    chicken12 New Member Thanks!
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Please post a screenhsot of the mail filter rule that you created and of the "Tag Level" tab of the spamfilter policy that you assigned to this mailbox.
  7. chicken12

    chicken12 New Member

    Till, Attached are three screenshots.
    #1 is a screenshot of the mailfilter setup for the email box in question. At first I tried just checking the "Move Spam Emails to Junk" and that did not work so I added the SPAM rule myself.

    #2 is the actually SPAM rule I added myself

    #3 is the spam filter policy (the policy named Normal) I have assigned to both the domain and email box for this user. The policy seems to be working fine as it is tagging all the email correctly as ***SPAM*** but it just seems the filtering rules are not applying.

    Thanks for your help!!!!

    Attached Files:

  8. kaschig

    kaschig New Member

    Hi Till,

    maybe the problem results by the spam/mail filter/rules setup which is not intuitive (in my opinion).

    There are two 'tag levels'.

    I thought on first entering that page (and some time after...) that 'level 2' is just chance to get a different markup of already spam-marked mails. Some testing brought to me:

    - Spam tag level is for setting X-Spam-Level and switching the subject ("tagged_above" in X-Spam-Status)
    - Spam tag level 2 is for setting the X-Spam-Flag to YES ("required" in X-Spam-Status)

    But there seems to be a problem(?) left when level 2 is left at '0' and level 1 is somewhat higher - in that case reaching the level 1 will set level 1 AND level 2 active, otherwise none of them get ruled.

    So if You just set "Level 1" to a value (and leave the other unchanged - so they result to "0") every Spam Mail will be deleted...

    So I decided to set Level 2 to the same value as Level 1 and set killed to 50... but that dependes to Your own bias.
  9. till

    till Super Moderator Staff Member ISPConfig Developer

  10. chicken12

    chicken12 New Member

    Till thanks for the pointers on the rules. Do you have any pointers on how I can troubleshoot the mail filters not working? Thanks
  11. chicken12

    chicken12 New Member

    ^^^ anyone have any ideas? I dont see ISPConfig creating any .mailfilter files. Should it be? Or is maildrop pulling those from SQL? Thanks
  12. chicken12

    chicken12 New Member

    anyone have any ideas? Thanks!!
  13. kaschig

    kaschig New Member


    where have You looked for the .mailfilters?

    They are located in /var/vmail/mailfilters/<domain>/<account>

  14. chicken12

    chicken12 New Member

    No .mailfilter files are being created even though I am putting stuff in the ISPconfig UI. Thanks
  15. chicken12

    chicken12 New Member

    I just checked and it is also not creating the .autoresponder files. Is there a way enabled debugging in ISPConfig to see why it is not creating these files? Thanks
  16. chicken12

    chicken12 New Member

    Ok, I just enabled debugging. I see it pickup the change but dont see any files being created.

    22.04.2010-01:07 - DEBUG - Set Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
    22.04.2010-01:07 - DEBUG - Found 1 changes, starting update process.
    22.04.2010-01:07 - DEBUG - Call function 'user_update' in plugin 'mail_plugin' raised by event 'mail_user_update'.
    22.04.2010-01:07 - DEBUG - Updated Maildir quota: su -c 'maildirmake -q 0S /var/vmail/' vmail
    22.04.2010-01:07 - DEBUG - Processed datalog_id 474
    22.04.2010-01:07 - DEBUG - Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock

  17. chicken12

    chicken12 New Member

    Anyone have any ideas on how I can debug this further? Thanks
  18. chicken12

    chicken12 New Member

    Sorry not trying to be a pest. I really need to fix this. Anyone have any ideas on why ISPConfig is not creating the files? Thanks!
  19. iovo

    iovo New Member

    I 've same problem with opensuse 11.2 and ISPConfig
  20. chicken12

    chicken12 New Member

    Glad its just not me. I have been playing around with this and cannot figure it out. Anyone got any ideas on where to look next? Thanks

Share This Page