Mail moving from old (qmail) to new (vmail) server

Discussion in 'Server Operation' started by sigiberlin, Jul 23, 2014.

  1. sigiberlin

    sigiberlin New Member


    i'm in the process of moving all my webs from my old server to the fresh installed server with ISPConfig.

    i moved one domain, changed the IP-Adress at Schlund, that worked.
    i added an email adress, made a .tar.gz on the old server that includes all dirs and files from the MailDir, moved that to the new server, located the new dir for the then new adress, and copied all from the .tar.gz to that.
    in putty i can see all dirs and all files.
    if i use my mail client (Thunderbird) to get all of that from the new server, i only see INBOX with Junk and Trash as subdirs.

    where are my mails?

    directory structure of the old MailDir is

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    You might to have to resubscribe to the imap folders in thunderbird.
  3. sigiberlin

    sigiberlin New Member

    thats what i do, but the resubscribe window doesnt show me the folders i listet above, only INBOX, Junk and Trash

    ont he old server there are folders that are on the same level as INBOX, and these are not whon in the subscribe window...

    maybe its that with the period as the first char in the name?
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    No, mail folder names start always with a period.

    Check the owners and permissions, all files and folders have to be owned by user and group "vmail".

    If you use dovecot, then the directories you listed above have to be in /var/vmail/domain.tld/user/Maildir/

    if you use courier, then the above folders have to be in /var/vmail/domain.tld/user/

    you should also check this in webmail. thunderbird has sometimes caching problems when a maildir is moved, has this yesterday with a client. readding the account in thunderbird fixed it.
  5. sigiberlin

    sigiberlin New Member

    thanks. seems it was the caching problem. restarted Thunderbird, and voila
  6. sigiberlin

    sigiberlin New Member

    interesting sidenote:

    chown -R vmail:vmail * didnt work as i thought it should, meaning it didnt change the owner and group of the individual mail files when i issued that in /var/vmail/domain.tld/user/. i had to go into every subdir (say, .Facebook) and do it again, that worked then...
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    A file starting with a dot is a hidden file on Linux, so it is not covered by the command you used. What waorks is either:

    chown -R vmail:vmail .*

    when you are inside the directory or

    chown -R vmail:vmail /var/vmail/domain.tld/user

    when you are in another directory.

Share This Page