Mail Server Setup With Exim, MySQL, Cyrus-Imapd, Horde Webmail On Centos 5.1 - works?

Discussion in 'HOWTO-Related Questions' started by gsp, Oct 10, 2008.

  1. gsp

    gsp New Member

    Mail Server Setup With Exim, MySQL, Cyrus-Imapd, Horde Webmail On Centos 5.1 - WORKS

    Hi there,

    i am a linux newbie and trying for some weeks now this 'how to' guide... After many many hours of reading my conclusion is that this guide doesn't work as it is!

    I don't know if the problem is that i tried to install on CentOS 5.2 but i found several issues that are not covered in this guide as cyrus admin user, permissions, firewall and SELinux settings that prevent system for normal operation... Now after all this period of format and setup and format and setup again, i have reached the point that even that i have an admin user [email protected] (horde & cyrus), on cyrus saslauthd this user name is not accepted from telnet tests... i thing there is some kind of 'bugs' on the authorization part...

    PLEASE if anyone managed to make this work to post some basic details on how i can make this work!!

    And for people who write these 'how to's' , please don't think that everything is supposed to be known!

    Thanks in advance
    Last edited: Nov 24, 2008
  2. topdog

    topdog Active Member

    There is no way a howto can cover every aspect needed to configure a system, it is expected that as a user following a howto you are capable of comprehending normal system admin tasks.

    That howto in its present form works fully with Centos 5.1 i have a running xen image of it on my dev machine.
  3. gsp

    gsp New Member

    Hi, thanks for the answer. I think that i CAN accomplish normal admin tasks, and i had no bad intentions with my message... Instead i am reading for many hours all these days... Maybe its the wrong OS version (minor differences?)... But i am searching for CentOS 5.1 and its nowhere... only 5.2... is there any links that i can download this image?

  4. topdog

    topdog Active Member

    Okay maybe if you state exactly what your problem is then i could help.
  5. gsp

    gsp New Member

    Thanks for your willing to help!..

    So, after many many re-installs and re-configurations i have reached at this point:

    -New accounts are created, they are able to send e-mails

    -If the administrator user creates a folder there is no-way to delete it afterwards (permission denied)

    -Isn't needed to create the cyrus admin user first? Because in config files there is an account cyrus with blank password...and of course imp cannot login..

    -Finally there is something with horde's config because when first loading a page not all menus are shown except if i press reload button

    When i was installing the packages i noticed some errors on php packets about 'file not found' from tmp directory and something like this but couldn't find any logs for this...

    I know there are a lot and various problems, thats why i am wondering if they are due to different version from 5.1 to 5.2...

    Thank you for your time:)
  6. topdog

    topdog Active Member

    It could be the version difference. The admin user cyrus is just a backup user, the admin user in the mysql database is the user to be used to configure stuff.

    Given imp cannot login does it mean users cannot see their mail ? if so does a normal connection on the command line authenticate ?
  7. gsp

    gsp New Member

    I thought also the same about the admin user, but as it seems its not a 'real' admin... he can create folders but he cannot delete them...

    Users can login from command line and also they can create their own folders AND delete them after...

    I don't know, lot of weird things happening... do you know if i can find any where a 5.1 CentOS isos for download?

    Thanks again
  8. topdog

    topdog Active Member

  9. gsp

    gsp New Member

    thanks, but unfortunately this was the place i downloaded my isos.. there are only 5.2 links and not 5.1... :(
  10. topdog

    topdog Active Member

  11. gsp

    gsp New Member

    many thanks, i'download them and try again the guide from scratch...

    I'let you know for my results!

  12. gsp

    gsp New Member

    Hi there. I am back again but disappointed... Installed the 5.1 version and saw no differences at all...

    Followed again step by step the guide but nothing worked... I have also noticed the differences in some paths and between configuration files...

    I don't want to bother you but please if there are other people who used this guide and made this worked please report i so stupid or what?

    Thank you
  13. space007

    space007 New Member

    yeah, same problem :(, I went with using this howto, and found diffrences in the howto and 5.2, my horde was using xml config files, but in the howto is just php code :confused:

    Anyway at the end I got stuck at

    Create Admin User
    * Create a file admin.sql and add the following (modify the password to suite you)

    SQL query:
    REPLACE INTO horde_users( user_uid, user_pass )
    VALUES (
    '[email protected]', md5( '123456' ) ,
    MySQL said: Documentation
    #1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ')' at line 5 
    # mysql -V
    mysql Ver 14.12 Distrib 5.0.45, for redhat-linux-gnu (i686) using readline 5.0

    after some research:

    I was able to create an Administrator with:

    -- $Horde: horde/scripts/sql/script.initial_horde_user.sql,v 1.1 2004/09/18 17:20:59 chuck Exp $
    -- This script will create an initial user in a horde_users table. The
    -- password being used is 'admin', which you should change
    INSERT INTO horde_users (user_uid, user_pass) VALUES ('Administrator', '21232f297a57a5a743894a0e4a801fc3');
    password was `admin`

    after the login I get a blank page ..

    anybody ?
    Last edited: Nov 18, 2008
  14. gsp

    gsp New Member

    at least i don't feel so stupid... this is a proof that there are many errors in this how to...

    To your problem now, i override this problem by removing the comma after the password line... (it waits for another expression).

    After this , the script works... but it would be perfect if this was the only problem...

    If there is any volunteer out there who made it to work may be he would like to suggest any corrections... :eek:

  15. topdog

    topdog Active Member

    Guys that howto was written 6 months ago using it now YMMV, just like the other poster stated certain things have changed. The sql error should be fairly simple to fix that is just a typo all u need do is remove the comma.
  16. space007

    space007 New Member

    Lets be positive, finding this kind of typos even errors, is beneficial for all of us. As I used this HowTo on CentOs 5.2 with current version of available software updating the HowTo will be a peace of cake :)

    ITS FIXED, repeat, I , yes yes, I made a typo in horde/imp/config/server.php, there was one <?php to many. Found it out from the web server logs. I can now login to horde.

    Now my final step is to get external pop3 accounts to the virtual users mailbox. I thought of using fetchmail, will look into it.

    If anybody has an idea, I am open for suggestions.

  17. topdog

    topdog Active Member

    Horde allows you to do that, u can fetchmail from other accounts, check the settings i have not used it myself though.
  18. space007

    space007 New Member

    1. After login in to horde (which takes a bit longer, guess is trying to access imap) I got the left menubar, in the center another login screen where is "Login failed"

    horde log:
    Nov 19 11:18:32 HORDE [error] [imp] FAILED LOGIN to localhost:143[imap/notls] as Administrator [on line 258 of "/usr/share/horde/imp/lib/Auth/imp.php"]
    2 And I just found out that I need also a pop3 server on this box :(
    no idea what to do now :eek:

    Any idea how can I integrate a pop3 in this setup ?
  19. space007

    space007 New Member

    this is because in cyrus from the start I commented out pop3 :p
    and the applicationt is on pop3 port...

    I still got auth failed

    Nov 19 12:58:52 server pop3[13812]: badlogin: server [] plaintext administrator SASL(-13): authentication failure: checkpass failed
    Nov 19 12:58:52 server pop3[13875]: auxpropfunc error no mechanism available 
    Nov 19 12:58:52 server saslauthd[13876]: do_auth         : auth failure: [user=administrator] [service=pop] [realm=] [mech=pam] [reason=PAM auth error]
    # /etc/init.d/saslauthd status
    saslauthd (pid 13447) is running...
    # /etc/init.d/cyrus-imapd status
    cyrus-master (pid 10765) is running...
    # lsof -i | grep cyrus
    cyrus-mas 10765   cyrus    7u  IPv6  43998       TCP *:imap (LISTEN)
    cyrus-mas 10765   cyrus   10u  IPv4  44000       TCP *:imap (LISTEN)
    cyrus-mas 10765   cyrus   13u  IPv6  44005       TCP *:pop3 (LISTEN)
    cyrus-mas 10765   cyrus   16u  IPv4  44007       TCP *:pop3 (LISTEN)
    cyrus-mas 10765   cyrus   19u  IPv4  44011       TCP localhost.localdomain:sieve (LISTEN)
    imapd     10772   cyrus    4u  IPv6  43998       TCP *:imap (LISTEN)
    pop3d     10773   cyrus    4u  IPv6  44005       TCP *:pop3 (LISTEN)
    imapd     13858   cyrus    4u  IPv4  44000       TCP *:imap (LISTEN)
    pop3d     13875   cyrus    4u  IPv4  44007       TCP *:pop3 (LISTEN)
    imapd     14088   cyrus    4u  IPv4  44000       TCP *:imap (LISTEN)
  20. topdog

    topdog Active Member

    Are u not using the full email address for logon ? As sasl is seeing only the user part.

Share This Page