Mailbox Size Limits

Discussion in 'General' started by palkat, Sep 11, 2005.

  1. palkat

    palkat New Member

    In the documentation (PDF file) for ISPConfig shows on page 55 you can adjust the mail box size limit for a user. Mine does not for any of the domains I setup. I did give my domains "-1" (unlimited) server space when i set them up if that effects anything.

    Is the mailbox size limit gone in my version of ISPConfig 2.0.8?

    I had this brought to my attention when my brother on AOL tired to send a 10meg zip file to my email and he said it was bounced back with a message saying there is not enough space on my mail server (ispconfig).

    The same message he sent me went to a freinds mail account on verision no problem. I sent my self from hotmail a 5meg attachment to my ispconfig account no problem so then i tried a 10meg and it was bounced back like my brothers. ISPConfig is stop large emails.

    If it matters my ISPConfig mail account is doing SPAM and VIRUS protection for my domain in ispconfig too.

    How do we correct this for large attachemnts?

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The mailboxsize fild is only available when you have an mbox install.

    If you have maildirs, the the quota of the website (group quota) and the quota of the user (user quota) will apply.
  3. palkat

    palkat New Member

    Thanks Till,
    So I continued to play with my mailbox more and found i can accept as many 5meg email messages as i want with the "-1" size but, i cannot accept a message with an attachment larger than 5+meg. So how do I change the aceptance size per message so i can accept say a 10+meg attachment?
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    This is not a limit in ISPConfig. Check your postfix for a message size limit. (if i remember correctly, the variable is named max_message_size)
  5. falko

    falko Super Moderator Howtoforge Staff

    This has nothing to do with ISPConfig, it's a setting of your Postfix.

    postconf -e 'message_size_limit = 20000000'
    postconf -e 'mailbox_size_limit = 100000000'
    This will accept messages of sizes up to 20000000 bytes, and the max. mailbox size is then limited to 100000000 bytes. Use whatever values you like. Restart Postfix afterwards:
    /etc/init.d/postfix restart
  6. H2SO4

    H2SO4 New Member

    how can i change the maximum mailbox size ?
    if i set the "mailbox space mb" to -1 in ispconfig, then showed this in the webmail : "Quota limit: Used 2783Kb of 204800Kb available".
    i want to change this value, if possible. :)
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    If you set the mailbox size to -1, the mailbox is not limited in size.
  8. H2SO4

    H2SO4 New Member

    ok thx.
    but why "of 204800Kb available" instead unlimited, in the ueimiau webmail ?
    a webmail bug, or what ? :)
    if i set to 50 then showed the good value in webmail too.

    i've changed the mailbox_size_limit in postfix settings from 0 to 52428800 (50mb) and works fine.
    just a little problem that if the mailbox is full, the error message was "can't create user output file" instead quota exceeded. :)
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    It is most likely a bug in the webmail program.

Share This Page