Mailgraph with Debian 9 (Apache)

Discussion in 'Installation/Configuration' started by bluethunder82, Dec 1, 2018.

  1. bluethunder82

    bluethunder82 Member

    Good morning,
    I've been trying to troubleshoot why Mailgraph is not working on my fresh install of Debian 9.

    What I've done:
    - Installed the software packages via the Perfect Setup (
    - Setup website with CGI and SuEXEC both checked.
    - Installed mailgraph using apt-get (essentially followed these steps:
    - Moved mailgraph.cgi to the cgi-bin folder and changed ownership to match the site.
    * I did however learn that the default location has changed. (

    When I visit: I get the HTML served with no graphs displayed. It appears as if the images are not being created in the temp directory in /var/lib/mailgraph. When I disable SuEXEC in the web interface and wait ~5 minutes I can reload the mailgraph.cgi and everything is displayed correctly.

    From what I can tell it is a permissions issue but not sure where it is: ISPConfig, SuExec, or mailgraph's install.

    There are no errors in suexec.log or access.log for apache2.

    Any troubleshooting thoughts would be appreciated.
  2. nekic

    nekic New Member

    Any solution to this? Have same issue. HTML is loaded, images not. When i try to open direct image, here is error:
    EDIT: solved. Maybe someone will find this post so here is what I did

    1. followed and have in mind that new location of mailgraph cgi is cp -p /usr/share/mailgraph/mailgraph.cgi
    After that, I did setup correct owner of files (chown) but images was not loading. Solution was to deactivate SuEXEC in ISPConfig options. After I reactivated it still worked.
    Last edited: Feb 3, 2020

Share This Page